Got stuck with SSD FDE and how to get it done.

Discussion in 'PC Hardware' started by goardenfreeman, Jan 20, 2016.

  1. goardenfreeman

    goardenfreeman MDL Novice

    Jul 22, 2014
    13
    0
    0
    Hello Guys,

    I seriously don't know where to go now, so I went to you.
    My Problem:
    I have an Fujitsu E754 and got an special request to fit this one with an FDE SSD, in my case the 850 Pro from Samsung, it seems like Fujitsu just re-brands this one for themselves, so it should be the same.

    Now I tried everything I know of, than everything what's been written on the Internet and I just can't get it to work.

    Often, I read something about an new BIOS entry in which you can set a password and It doesn't seem like I got this one.

    So, maybe here is some Fujitsu expert or FDE expert or BIOS expert who knows about this stuff more than the Internet.

    If you do, please, stand up and share you're knowledge!

    Greetings

    P.S. You can order one directly from Fujitsu with this feature enabled, so if they get it done, it can be done!
     
  2. NICK@NUMBER11

    NICK@NUMBER11 MDL Expert

    Mar 23, 2010
    1,354
    633
    60
    do you see the new hard drive in bios?
    what make fde ssd
     
  3. goardenfreeman

    goardenfreeman MDL Novice

    Jul 22, 2014
    13
    0
    0
    #3 goardenfreeman, Jan 20, 2016
    Last edited: Jan 20, 2016
    (OP)
    Yes, in the BIOS I see the new hard drive and it got recognized as an 850 Pro which is correct too!
    Sorry if I got you wrong, but what do you mean with "what make fde ssd"? Model Nr? Or....?

    Another Question, using Windows 7 Pro on this one, Win 8 or < is not an special requierment for this feature, right?

    Thanks for your help!!!
     
  4. goardenfreeman

    goardenfreeman MDL Novice

    Jul 22, 2014
    13
    0
    0
    Yes, I read the same article, it's all setup in UEFI mode and no, none of the Intel Magican Features can be the FDE, cause the original System came with an "rebranded" EVO which can use all of the shown Features too.
    So I'm missing the Feature "ATA-security extension" or however Fujitsu may call it. How can I enable this one? Is it just locked away and can be enabled by Fujitsu Tools?

    My head is exploding right now...
     
  5. goardenfreeman

    goardenfreeman MDL Novice

    Jul 22, 2014
    13
    0
    0
    I installed the BIOS Update as soon as I got my hands on it, so there's nothing newer out there :S.
    Also I read the manual and yes I got a Security register in my BIOS, but I wasn't offered to find ATA-Security-Extension or sth. which I can only set if I got the 850 Pro (FDE SSD) and can't set is with the 840 EVO (fujitsu branded one which doesn't support FDE). Or am I just missing sth.?

    Greetings and thanks again!
     
  6. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,392
    1,465
    180
    have you tried reset defaults in bios ? id imagine so.. what about prior version bios ?
    or firmware of fde ssd ? i think fuji add something to theirs.. :death:
     
  7. goardenfreeman

    goardenfreeman MDL Novice

    Jul 22, 2014
    13
    0
    0
    Yes, I reseted it multiple times, cause I figured maybe it has sth. to do with it, but no it doesn't look like it had ...
    Flashed the 2 oldest BIOS right away after your hint, but no change. I also tried a fujitsu service tool (DIFS) which added a new BIOS point, but i figured out by now that it has nothing to do with what I'm looking for.
    Also tried that, even looked in the Samsung Software, used the secure erase (for no reason to this topic) but no.

    By now I'm guessing it could have sth. to do with an Nr. Fujitsu gave them, I mean like the branded W-LAN Chips e.g. in Lenovo where you have to unlock it so it bypasses the whitelist or add one to the original Intel Chip.
    Could this be? Or is there any knowledge about sth. in Fujitsu branded SSD's?

    Greetings
     
  8. Flipp3r

    Flipp3r MDL Expert

    Feb 11, 2009
    1,530
    655
    60
    I must be missing something. What exactly is the problem? What can't you get to work?
     
  9. goardenfreeman

    goardenfreeman MDL Novice

    Jul 22, 2014
    13
    0
    0
    Well I'm missing an special point in the BIOS under "Security" in which I can enable ATA Security Extension or sth. like it.
    Cause if I got it all figured out right its needed, so it enables FDE?!
    I also read an article on Lenovos Support Page and the Installation Guide they gave (if you don't see "ATA Security Extension") is durable on any normal SSD too (840 EVO e.g.) so it could not truly be FDE encrypted?!

    Greetings and still thank you guys very much!