[GUIDE] Add Store to Windows 10 EnterpriseS SKU (LTSB/LTSC)

Discussion in 'Windows 10' started by Tito, Aug 9, 2016.

  1. BAU

    BAU MDL Addicted

    Feb 10, 2009
    702
    1,284
    30
    #901 BAU, Nov 4, 2019
    Last edited: Nov 4, 2019
    Have you tried right-click Desktop - New - Shortcut:
    cmd.exe /c start ms-windows-store:
    Such lnk should be pin-able anywhere..

    The explorer shortcut works as well:
    explorer.exe shell:appsFolder\Microsoft.WindowsStore_8wekyb3d8bbwe!App
     
  2. windows builder

    windows builder MDL Expert

    Sep 13, 2017
    1,855
    1,124
    60
    It works! :)
    But how to replace the icon? Where is the Store icon located?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. BAU

    BAU MDL Addicted

    Feb 10, 2009
    702
    1,284
    30
    The explorer shortcut works as well:
    explorer.exe shell:appsFolder\Microsoft.WindowsStore_8wekyb3d8bbwe!App

    Just pick another icon from explorer then.
     
  4. windows builder

    windows builder MDL Expert

    Sep 13, 2017
    1,855
    1,124
    60
    Now even better. :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. BAU

    BAU MDL Addicted

    Feb 10, 2009
    702
    1,284
    30
    Apps don't use classic shortcuts, don't come with classic icons but use png file resources.
    But the Explorer one resembling a store works good enough :)
     
  6. windows builder

    windows builder MDL Expert

    Sep 13, 2017
    1,855
    1,124
    60
    yep :)

    Searched here:
    C:\Windows\System32\shell32.dll;
    C:\Windows\System32\imageres.dll;
    C:\Windows\System32\ddores.dll
    C:\Windows\SystemResources\imageres.dll.mun

    Nothing.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. windows builder

    windows builder MDL Expert

    Sep 13, 2017
    1,855
    1,124
    60
    #907 windows builder, Nov 4, 2019
    Last edited: Nov 4, 2019
    find here:
    C:\Program Files\WindowsApps\Microsoft.WindowsStore_11911.1001.8.0_x64__8wekyb3d8bbwe\Assets\AppTiles

    edit .png to .ico:
    2019-11-04 001.png
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. bobf222

    bobf222 MDL Novice

    Oct 26, 2019
    2
    0
    0
    How do you actually get the xbox app to work on ltsc since 1903 is required for it.
     
  9. windows builder

    windows builder MDL Expert

    Sep 13, 2017
    1,855
    1,124
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. bobf222

    bobf222 MDL Novice

    Oct 26, 2019
    2
    0
    0
    #910 bobf222, Nov 10, 2019
    Last edited: Nov 10, 2019
  11. Ciocan

    Ciocan MDL Novice

    Nov 10, 2019
    4
    1
    0
    Hi guys, do you have any idea why the add-store.cmd wont open when i run it as an administrator ? If I just open it by double clicking on it... it says " run the script as an administrator " ... and if i run it as an administrator it wont open ! How can i solve this ?
     
  12. windows builder

    windows builder MDL Expert

    Sep 13, 2017
    1,855
    1,124
    60
    AV?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. Ciocan

    Ciocan MDL Novice

    Nov 10, 2019
    4
    1
    0
    I dont really know what AV means, but i guess you're either asking about the Windows Edition & Version or you suggest me to turn my Anti Virus off while doing it ?
    WIndows edition: Windows 10 Enterprise LTSC
    Version: 1809
    OS Build: 17763
     
  14. windows builder

    windows builder MDL Expert

    Sep 13, 2017
    1,855
    1,124
    60
    yes
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. Ciocan

    Ciocan MDL Novice

    Nov 10, 2019
    4
    1
    0
    I paused the antivirus protection ( if relevant i use : Eset nod 32 Antivirus 12 ) but it's still not working !
    Also, In the meantime i tried to install the Microsoft store on the other laptop i have ( with the same windows version and the same antivirus ) and it worked.
    Do you have any suggestion ?
     
  16. Ciocan

    Ciocan MDL Novice

    Nov 10, 2019
    4
    1
    0
    Hi guys, I'm back and I actually solved the problem !
    Therefore if you are experiencing the same problem as i was... ( Script just opens and closes when ran in admin mode and if it's not ran in admin mode, it opens but says Error: Must be ran in Admin Mode ) you will just need to run it as an administrator from a folder which is not backed up by One Drive. It seems that was causing the program to not run.

    So basically, just extract & run the files from D partition... and it will work !

    I found this solution on this thread - https:// github.com/kkkgo/LTSC-Add-MicrosoftStore/issues/5 ( i will just leave it here as a tribute ).

    I hope this will help others too ! Thank you for trying to help and have a nice evening ! :)
     
  17. Mindseye72

    Mindseye72 MDL Novice

    Nov 20, 2019
    1
    0
    0
    fantastic worked like a charm downloading gears of war now sweet.
     
  18. y0ba91

    y0ba91 MDL Novice

    Nov 21, 2019
    9
    0
    0
    Hello

    I have Windows 10 LSTB 2016 and it did'nt work for me... are there common ways to fix that?
     
  19. y0ba91

    y0ba91 MDL Novice

    Nov 21, 2019
    9
    0
    0
    When I try the github pack I get the following:

    ============================================================
    Adding Microsoft Store
    ============================================================
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073D06, The package could not be installed because a higher
    version of this package is already installed.
    Windows cannot install package Microsoft.VCLibs.140.00_14.0.25426.0_x64__8wekyb3d8bbwe because it has version
    14.0.25426.0. A higher version 14.0.27810.0 of this package is already installed.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-0005-622e-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-0005-622e-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.VCLibs.x64.14.00.Appx
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (C:\LTSB-Add-Mic....x64.14.00.Appx:String) [Add-AppxPackage], Exception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073D06, The package could not be installed because a higher
    version of this package is already installed.
    Windows cannot install package Microsoft.VCLibs.140.00_14.0.25426.0_x86__8wekyb3d8bbwe because it has version
    14.0.25426.0. A higher version 14.0.27810.0 of this package is already installed.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-0005-772e-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-0005-772e-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.VCLibs.x86.14.00.Appx
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (C:\LTSB-Add-Mic....x86.14.00.Appx:String) [Add-AppxPackage], Exception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could not be registered.
    error 0x87AF0001: The Visual Elements extension failed while processing the Notification element.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-0000-8835-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-0000-8835-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.WindowsStore_11804.1001.813.0_neutral ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : WriteError: (C:\LTSB-Add-Mic...bbwe.AppxBundle:String) [Add-AppxPackage], IOException
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    ============================================================
    Adding App Installer
    ============================================================
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could not be registered.
    error 0x87AF0001: The Visual Elements extension failed while processing the Notification element.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-000f-b231-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-000f-b231-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.DesktopAppInstaller_1.8.4001.0_neutra ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : WriteError: (C:\LTSB-Add-Mic...bbwe.appxbundle:String) [Add-AppxPackage], IOException
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    ============================================================
    Adding Store Purchase App
    ============================================================
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073D06, The package could not be installed because a higher
    version of this package is already installed.
    Windows cannot install package Microsoft.VCLibs.140.00_14.0.25426.0_x64__8wekyb3d8bbwe because it has version
    14.0.25426.0. A higher version 14.0.27810.0 of this package is already installed.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-000e-eb44-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-000e-eb44-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.VCLibs.x64.14.00.Appx
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (C:\LTSB-Add-Mic....x64.14.00.Appx:String) [Add-AppxPackage], Exception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073D06, The package could not be installed because a higher
    version of this package is already installed.
    Windows cannot install package Microsoft.VCLibs.140.00_14.0.25426.0_x86__8wekyb3d8bbwe because it has version
    14.0.25426.0. A higher version 14.0.27810.0 of this package is already installed.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-000c-db46-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-000c-db46-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.VCLibs.x86.14.00.Appx
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (C:\LTSB-Add-Mic....x86.14.00.Appx:String) [Add-AppxPackage], Exception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073D06, The package could not be installed because a higher
    version of this package is already installed.
    Windows cannot install package Microsoft.NET.Native.Framework.1.3_1.3.24201.0_x64__8wekyb3d8bbwe because it has
    version 1.3.24201.0. A higher version 1.3.24211.0 of this package is already installed.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-0008-c744-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-0008-c744-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.NET.Native.Framework.x64.1.3.appx
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (C:\LTSB-Add-Mic...rk.x64.1.3.appx:String) [Add-AppxPackage], Exception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073D06, The package could not be installed because a higher
    version of this package is already installed.
    Windows cannot install package Microsoft.NET.Native.Framework.1.3_1.3.24201.0_x86__8wekyb3d8bbwe because it has
    version 1.3.24201.0. A higher version 1.3.24211.0 of this package is already installed.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-0009-872f-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-0009-872f-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.NET.Native.Framework.x86.1.3.appx
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (C:\LTSB-Add-Mic...rk.x86.1.3.appx:String) [Add-AppxPackage], Exception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could not be registered.
    error 0x87AF0001: The Visual Elements extension failed while processing the Notification element.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-0000-6636-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-0000-6636-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.StorePurchaseApp_11706.1707.7104.0_ne ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : WriteError: (C:\LTSB-Add-Mic...bbwe.appxbundle:String) [Add-AppxPackage], IOException
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    ============================================================
    Adding Xbox Identity Provider
    ============================================================
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073D06, The package could not be installed because a higher
    version of this package is already installed.
    Windows cannot install package Microsoft.VCLibs.140.00_14.0.25426.0_x64__8wekyb3d8bbwe because it has version
    14.0.25426.0. A higher version 14.0.27810.0 of this package is already installed.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-0008-ec44-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-0008-ec44-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.VCLibs.x64.14.00.Appx
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (C:\LTSB-Add-Mic....x64.14.00.Appx:String) [Add-AppxPackage], Exception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073D06, The package could not be installed because a higher
    version of this package is already installed.
    Windows cannot install package Microsoft.VCLibs.140.00_14.0.25426.0_x86__8wekyb3d8bbwe because it has version
    14.0.25426.0. A higher version 14.0.27810.0 of this package is already installed.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-000c-4a47-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-000c-4a47-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.VCLibs.x86.14.00.Appx
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (C:\LTSB-Add-Mic....x86.14.00.Appx:String) [Add-AppxPackage], Exception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073D06, The package could not be installed because a higher
    version of this package is already installed.
    Windows cannot install package Microsoft.NET.Native.Framework.1.3_1.3.24201.0_x64__8wekyb3d8bbwe because it has
    version 1.3.24201.0. A higher version 1.3.24211.0 of this package is already installed.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-0003-e832-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-0003-e832-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.NET.Native.Framework.x64.1.3.appx
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (C:\LTSB-Add-Mic...rk.x64.1.3.appx:String) [Add-AppxPackage], Exception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073D06, The package could not be installed because a higher
    version of this package is already installed.
    Windows cannot install package Microsoft.NET.Native.Framework.1.3_1.3.24201.0_x86__8wekyb3d8bbwe because it has
    version 1.3.24201.0. A higher version 1.3.24211.0 of this package is already installed.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-0008-7046-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-0008-7046-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.NET.Native.Framework.x86.1.3.appx
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (C:\LTSB-Add-Mic...rk.x86.1.3.appx:String) [Add-AppxPackage], Exception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could not be registered.
    error 0x87AF0001: The Visual Elements extension failed while processing the Notification element.
    NOTE: For additional information, look for [ActivityId] ddc72cc8-a0c1-000e-9345-c7ddc1a0d501 in the Event Log or use
    the command line Get-AppxLog -ActivityID ddc72cc8-a0c1-000e-9345-c7ddc1a0d501
    At line:1 char:1
    + Add-AppxPackage -Path Microsoft.XboxIdentityProvider_2017.605.1240.0_ ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : WriteError: (C:\LTSB-Add-Mic...bbwe.appxbundle:String) [Add-AppxPackage], IOException
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
     
  20. windows builder

    windows builder MDL Expert

    Sep 13, 2017
    1,855
    1,124
    60
    The package could not be installed because a higher
    version of this package is already installed.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...