Had to reinstall ESXi, now my guest won't connect to the network

Discussion in 'Virtualization' started by foxyrick, Jan 3, 2016.

  1. foxyrick

    foxyrick MDL Junior Member

    Aug 25, 2011
    61
    21
    0
    #1 foxyrick, Jan 3, 2016
    Last edited: Jan 3, 2016
    ETA: Well, I gave up and started to install a new guest. I went back into this one to copy some settings and... the darned network was working! I have no idea what it was that I did that fixed it, after four hours of faffing about. Probably the gremlin got bored and moved somewhere else.

    ---

    Can anyone shed any light on this please?

    The USB drivekey in my server in the loft died yesterday, so I reinstalled the same version (the very latest ESXi 6U1) on a new key, recreated my virtual network and fired up the main guest; server 2008R2.

    The guest now has no network connectivity, at all. It has two virtual NICs, one on my LAN and the other for my internet link. All the settings are correct in ESXi and the guest. Note that other guest machines, with windows XP, work perfectly. It's just this guest; the important one.

    I've turned off the firewall completely, uninstalled and reinstalled the NICs (and then reconfigured them) in device manager, reset the TCP/IP, and spent four hours fiddling in network and sharing with no luck. Once, I got connectivity to my LAN and could ping out from the server to my PC, but not the other way (no firewall though). So, I rebooted and lost even that again when it restarted, never to return.

    IPv6 does not work any more than IPv4 (I'm fully IPv6 enabled here with my own /48 global prefix).

    I'm at a loss... in the network and sharing centre, things just don't look right. My networks are coming up occasionally as private, or public, with a type of WAN(?) or just unidentified. I've tried changing the type by going through the local security settings to allow it. I cannot get DHCP on either NIC and if I try, I just get that 169... address. Both sides have a DHCP server (the guest doesn't do DHCP itself and is usually statically configured of course). Sometimes I get an exclamation mark on the network icon, sometimes not. Sometimes it says 'no network connectivity', or not. Either way, it doesn't have any.

    Oh, I also cannot upgrade vmware tools although it says an update is available - nothing happens when I try. Possibly related?

    Nothing works. I can usually solve issues like this (I'm no newbie) but this time I'm absolutely stumped.

    The guest seems perfectly fine, other than this issue.

    I've posted this in virtualization instead of the server group because I think it more likely relevant here, given the cause.