Hard disk problem..........

Discussion in 'PC Hardware' started by hjharshraj, Mar 1, 2010.

  1. hjharshraj

    hjharshraj MDL Junior Member

    Sep 7, 2009
    53
    1
    0
    hello friend

    I m facing a new kind of problem now a days..
    I have 2 HDD in my pc. 1 of them is Sata disk.....The problem is that when i install windows xp it works properly but when i install windows 7 it doesnt work properly and computer hanged. at time using win 7. i cant work propely due to that disk....

    What should do to solve this proble... I format that drive and also wipe to solve problem but there is no result

    pls help me to solve problem

    sorry for my poor english:confused:
     
  2. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60
    So you can't boot into win7 ? or does it hang when logged in win7.
    If possible, try safe mode and check device manager if all drivers are without conflict and installed.
    See if you could update drivers where possible.

    If you can't boot into win7, and you can in xp,
    then check in your bios if sata is set as IDE or AHCI. There should be a setting somewhere that controls this.

    If it's set as AHCI, then reset it as ide and see if win7 boots and works.

    If this is the case, you will need to make an adjustment in registry if you want the drive to work in AHCI mode again, so get back to me.
     
  3. potpotjeng

    potpotjeng MDL Novice

    May 29, 2009
    43
    2
    0
    There could be a possibikity that your hard drive have bad sectors. I have experienced it my self that after i installed win 7 the computer either slows down ,hanged or got the blue screen. I used hard disk regenerator 1.71 to check my hard drive and it found 5 bad sectors. Was able to fix the bad sector problem via the same program.Formated the drive and installed win 7 again and it worked normally.