[HELP] Accidentally Crossflashed Bios (Sucessfully), need to revert!

Discussion in 'BIOS Mods' started by sirblackjack, Feb 2, 2013.

  1. sirblackjack

    sirblackjack MDL Novice

    Mar 6, 2010
    5
    0
    0
    I wanted to update the default ECS H77H2-M3 Bios, but accidentally I downloaded the ECS H67H2-M3 Bios.

    I used the ECS Utility that came with the latest bios.

    For some reason the utility never checked that it was flashing a different board, with different rom size. It just flashed.

    The good news is: The board is not bricked, and it works. I can get to Windows with no problems. It appears that both boards and chipsets are very similar, so the board is working. Bot Boards uses AMI bios.

    The problem is: I can't flash back to any H77H2-M3 Bios. There are two versions of the Bios for the board, with the first I tried with AFUDOS and AFUWIN and I get a "Rom file size does not match" error, no matter what commands I use.

    The latest bios comes included with the ECS Utility called CPU EVO II (I don't know how to extract the .rom from the utility). Anyway, I get an "ME Unlocked" error. There is a ME Unlock PIN on the board, I tried the utility with the pin shorted and unshorted with no avail.

    Any idea how I can flash the correct bios back?
     
  2. sirblackjack

    sirblackjack MDL Novice

    Mar 6, 2010
    5
    0
    0
    Can anyone help me extracting the .rom from an .exe file? (The latest H77H2-M3 bios)

    I tried with 7zip and Universal extractor.

    Link is: http download.ecsusa.com/dlfileecs/BIOSROM/H77H2-M3/120911_EVO.zip

    I might give it a shot with that .rom with afudos/afuwin

    Thanks!
     
  3. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,390
    1,464
    180
  4. sirblackjack

    sirblackjack MDL Novice

    Mar 6, 2010
    5
    0
    0
    LatinMcG thanks for your help. How did you extract the files?

    I used the extracted bios.bin file with afudos. I used afudos bios.bin /p /b /n /x /me

    After the flash was completed, I turned off the computer, removed the ME Unlock pin and cleared the CMOS.

    Unfortunately now it won't post. Black Screen, no beeps. Tried renaming the bios to AMIBOOT.ROM in FAT formatted USB and pressing CTRL-HOME keys, but nothing happens.

    I guess I bricked my motherboard, I don't know what went wrong!
     
  5. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,390
    1,464
    180
    i clicked update in the program then canceled.. made a folder next to .exe
    youre going to need a chip or a programer.