HELP: Computer loses connection to the Internet after restart

Discussion in 'Windows 7' started by TKnuckles, Dec 16, 2017.

  1. TKnuckles

    TKnuckles MDL Junior Member

    Dec 10, 2017
    63
    12
    0
    My router is TP-Link and after every restart my computer loses Internet access (LAN), so every time I have to restart the router to be connected again. I can access Internet on my phone with WiFi. My IP is Dynamic and I don't want to fiddle with router settings. Is there any solution for this?
     
  2. Joe C

    Joe C MDL Guru

    Jan 12, 2012
    2,477
    1,343
    90
    Not much info there...
    broadband, dsl or something else?
    Try the modem on another device, if it still drops on other wired devices and it's an older modem, might consider an upgrade of that modem. If it does not drop out on a different device then try disabling Energy Efficient Ethernet on your device

    (what ever that device is, you ought to tell us what the specs of your device with a model number)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. tonto11

    tonto11 MDL Addicted

    Jun 18, 2012
    594
    262
    30
    Like Joe C says we need more info
    There are two sides to the problem of a lan connection to a router

    1. the router.
    connect a second computer and log into the router so you can watch the connections
    and what they're doing
    With all working normally, unplug the lan at the computer
    after a time plug it back in and see if it will reconnect.
    watch what's going on in the router, any errors?


    2. the computer
    When it restarts is the network present in the devices list and is the card enabled
    does it try to connect
    does it request an ip address
    and errors on the computer or on the router monitored by the second computer?

    ...T
     
  4. dhjohns

    dhjohns MDL Guru

    Sep 5, 2013
    3,285
    1,731
    120
    Have you ticked the checkbox to automatically reconnect?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. OldMX

    OldMX MDL Senior Member

    Jul 30, 2009
    421
    141
    10
    dump that pos router and get a real one.
     
  6. tonto11

    tonto11 MDL Addicted

    Jun 18, 2012
    594
    262
    30
    got two TP-Links running in series
    they work fine

    ...T