[HELP] libOpenCL.so.1 is not a symbolic link - how to fix?

Discussion in 'Linux' started by wmh, Jun 3, 2016.

  1. wmh

    wmh MDL Junior Member

    Jun 30, 2015
    98
    15
    0
    #1 wmh, Jun 3, 2016
    Last edited by a moderator: Apr 20, 2017
    Hello everyone!

    I keep getting this error on terminal or in update manager:

    Code:
    Processing triggers for libc-bin (2.19-0ubuntu6.9) ...
    /sbin/ldconfig.real: /usr/lib/i386-linux-gnu/libOpenCL.so.1 is not a symbolic link
    I know it is related to amd video drivers but don't know how to fix it. :eek:

    Can anyone out there give me a hand? I'm on Mint 17.3 upgraded from 17.2 x64.

    Thanks in advance.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Tiger-1

    Tiger-1 MDL Guru

    Oct 18, 2014
    2,901
    3,029
    90
    #2 Tiger-1, Jun 3, 2016
    Last edited: Jun 3, 2016
    Hi wmh do you already attempt look on askubuntu.com :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. wmh

    wmh MDL Junior Member

    Jun 30, 2015
    98
    15
    0
    I'm checking it but I have to fix my windows not showing first. They disappeared after apt-get update / upgrade. :D

    Not even terminal window is displaying.

    Luckily I'm on dual boot with windows 7.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Tiger-1

    Tiger-1 MDL Guru

    Oct 18, 2014
    2,901
    3,029
    90
    @wmh humm attempt make one fresh install maybe solve this problem dude :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. thorin0815

    thorin0815 MDL Senior Member

    Jul 16, 2015
    428
    260
    10
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. wmh

    wmh MDL Junior Member

    Jun 30, 2015
    98
    15
    0
    #6 wmh, Jun 3, 2016
    Last edited by a moderator: Apr 20, 2017
    (OP)
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. thorin0815

    thorin0815 MDL Senior Member

    Jul 16, 2015
    428
    260
    10
    Make a system backup, for example with AOMEI Backupper Standard (Windows software which is free of charge) and test it. :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. wmh

    wmh MDL Junior Member

    Jun 30, 2015
    98
    15
    0
    #8 wmh, Jun 4, 2016
    Last edited: Jun 4, 2016
    (OP)
    Ok now I have a black screen after grub. Any ideas? :D

    R9 270 on 17.3 x64 mint cinnamon
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. wmh

    wmh MDL Junior Member

    Jun 30, 2015
    98
    15
    0
    #9 wmh, Jun 4, 2016
    Last edited by a moderator: Apr 20, 2017
    (OP)
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...