Help needed - BIOS not detecting installed memory after flash

Discussion in 'BIOS Mods' started by Antraman, Sep 3, 2010.

  1. Antraman

    Antraman MDL Novice

    Jan 1, 2010
    20
    1
    0
    #1 Antraman, Sep 3, 2010
    Last edited: Sep 3, 2010
    I have been unable to find any info on the net about this, so hope that MDL people can help.

    I just built a new machine using Asus M2N32-Sli Deluxe motherboard, installed Windows 7 x64 and got everything working fine. I flashed the BIOS to Beta 5002 and reboot, everything still working fine.

    I then used AwardTool.exe to create a SLIC version of 5002. The tool did verify OK at the end of the procedure, but I noticed there was one error in the log...something about an extra hash.

    I flashed the BIOS anyway, and PC booted up into Windows OK. I then checked Control Panel/System info and windows activation still said 30days grace period.

    So I thought SLIC didn't work properly, and then made another SLIC version of the BIN file. Restarted, flashed again, and when booting into Windows., got a BSOD.

    When I reboot and look in BIOS, I see in Basic tab, that Installed Memory was 0KB. Previously, it detected the 4GB RAM installed. Now it was only detecting 127KB usable memory...

    I allowed boot up to continue and got the Boot manager screen with options to boot Windows normally or do a windows system repair. I thought I would try a repair even though I didn't think it would help. I inserted Windows disk and ran repair, but got message "Insufficient RAMDISK memory, unable to continue" or something like that, then it went back to boot manager window.

    So then I re-flashed the BIOS with the original 5002.BIN file, and reboot, but BIOS would still not detect installed memory. I then rolled back to 2205.BIN version, but still same problem.

    I then tried to clear CMOS by removing clock battery and switching jumper for short time, then back. Rebooting, still the memory is not detected in BIOS.
    I then saw nijel's post in "BIOS-Recovery-procedures" thread about shorting the BIOS chip pins to get it into BIOS recovery mode, but it did not work for me.

    A techie friend suggested I reset DMI pool data, but I cannot find any options in BIOS to do this, and only references on the web that I checked, mentioned DMI pool data in relation to XP, whereas I am using W7x64

    So I am really stuck. Can anyone give me an idea what to do next?

    thx,
    Antra

    EDIT: RAM is Corsair XMS PC 6400 DDR2 which I have had in 2 other machines and never had any problem.
     
  2. vivek.krishnan

    vivek.krishnan MDL Novice

    Dec 13, 2009
    48
    7
    0
    Use a different bios version other than the beta. It might solve the problem. I have flashed a M2N68 with ASUS SLIC and yet not encountered any problems.
     
  3. NoJuan999

    NoJuan999 Experienced SLIC Tool Operator

    Jul 31, 2009
    9,919
    1,930
    300
    Try Flashing it from DOS (Bootable Floppy or USB) like this:
    awdflash.exe {type name of bios}.bin /cc/cd/cp/py/R
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    10,971
    10,542
    340
    Yes and use tha latest original bios (non beta). I assume you have tried to load setup defaults, save and exit...also checked if DIMMs are installed properly.
    Asus used at (older bioses) the reset ESCD option....

    Get the right awdflash from asus support loacted at your mainboard's section...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...