Help with unidentifiable HP Elitebook

Discussion in 'Windows Vista' started by bobbytomorow, Oct 24, 2012.

  1. bobbytomorow

    bobbytomorow MDL Novice

    Oct 22, 2012
    4
    0
    0
    I recently purchased a bunch of computer and networking hardware from an IT company that moved out of my city. One of the laptops included in my purchase is an unidentifiable HP Elitebook.

    I have determined that it is an 8440p from doing my own digging and was originally loaded with some sort of testing build of Vista business x86.

    Where I am stumped is that the BIOS is empty of any kind of system ID, CPU ID, model ID, serial ID etc... As a result I cannot ID any of the hardware from Windows other than CPUID helping me to determine that the CPU is a i5-520m.

    There is a BIOS warning and I cannot seem to disable or fix it. I have dug in these forums and tried a DMI CD image, burned it to disc but got a message of, "Device driver not found: 'MSCD001'" followed by, "Dude, the windows cd wasn't detected."

    Further there seems to be no way of identifying the laptop model number. There is no model ID around the bezel (refer to pics), none on the bottom of the laptop, no ID on the palm rest etc... NOTHING

    Any help fellas?

    h
     

    Attached Files:

  2. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,434
    1,486
    180
    have u tried the hp product detection on their site ?

    sometime u can open it and get hp part number on mobo.
    it could be a fake clone.. i had a fake sony netbook last year.
     
  3. bobbytomorow

    bobbytomorow MDL Novice

    Oct 22, 2012
    4
    0
    0
    Just tried "0 HP devices detected"

    Thanks but no cigar unfortunately
     
  4. anarchist9027

    anarchist9027 MDL Expert

    Oct 30, 2010
    1,320
    667
    60
    I had an HP Probook 4520s (and currently an Envy 17) and I know for a fact that the model info is under the battery. Have you checked there?
     
  5. bobbytomorow

    bobbytomorow MDL Novice

    Oct 22, 2012
    4
    0
    0
    There is a single purple/pink sticker under the battery with a barcode and 2 strings of numbers, although a search on HP turned up nothing

    Here is a pic

    rdtFg.jpg
     
  6. roirraW "edor" ehT

    roirraW "edor" ehT MDL Addicted

    Sep 1, 2007
    616
    215
    30
    Have you tried a Google search instead of just on HP's site?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. coleoptere2007

    coleoptere2007 MDL Guru

    Apr 8, 2008
    2,320
    1,190
    90
    Hello,

    If your laptop can start and launch the OS, then go to registry and you'll find your bios and product in HKLM\hardware\description\system\bios

    Hoping that this will help you :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. anarchist9027

    anarchist9027 MDL Expert

    Oct 30, 2010
    1,320
    667
    60
    This company must of had something to hide considering you cant find any info about the laptop to trace it to anything or identify it.
     
  9. anarchist9027

    anarchist9027 MDL Expert

    Oct 30, 2010
    1,320
    667
    60
    Or this could of been a prototype also because KCLSI18 is a model number and I cannot find it anywhere.
     
  10. EliteBookParts

    EliteBookParts MDL Novice

    Sep 26, 2012
    4
    1
    0
    Sorry this is an old thread but if necessary I have the tool to program this information into the laptop so it doesn't pop up. I will even provide you the model/serial from my personal 8440p for you to program in.
     
  11. Liebo

    Liebo MDL Member

    Jul 9, 2009
    133
    2
    10
    It looks like a hp ProBook 6450b.

    When HP ship you a new mainboard under warrenty, it comes the same, with no system IDs etc. This is so you can match the serial number up to the one on the chassis etc.

    In the BIOS, you can press "CTRL+A" then go to the System IDs screen and you can write them in yourself (anything will do until you find out what it is) then that message will not display for the time being. CTRL+A makes extra fields available that are greyed out in the System IDs where you add your own asset tag etc.