Help with Win 7 installation with new partition table?

Discussion in 'Windows 7' started by Razugen, Mar 4, 2013.

  1. Razugen

    Razugen MDL Novice

    Mar 4, 2013
    1
    0
    0
    Hello everyone,

    I recently bought a new Samsung laptop, and tried out Windows 8. Turns out, I can't stand it. So I went to install Win 7 instead. Booting from USB worked okay, but when trying to install to my primary partition, I get the message "windows cannot be installed on this disk. The selected disk is of the GPT partition style."

    Okay, Fine. I don't really need GPT, I can just make a new partition table using MBR instead of GPT. Booting GParted, I made a new partition table (wiping everything, but I didn't really want any of it anyways), so now I have a single ntfs partition under MSDOS/MBR instead of GPT. Here's where my problems start. Before the installation USB booted up great. Now, after the new table was created, when I power on the laptop, I get the Samsung load screen, followed by a blank screen with a blinking cursor. Win 7 install doesn't boot. However, GParted boots just fine, except I need to boot as UEFI OS instead of "UEFI and Legacy OS," which I assume is them trying to simplify things in my BIOS (Win 7 won't install except under Legacy OS, btw).

    In summary, what I have right now:

    1 USB with Windows 7 install
    1 USB with GParted
    1 Laptop with a single MBR NTFS Partition that for some reason doesn't want to boot Win 7 but likes GParted just fine.

    Can anyone help with this issue?
     
  2. PhaseDoubt

    PhaseDoubt MDL Expert

    Dec 24, 2011
    1,447
    277
    60
    If it were me, I'd recreate the Windows 7 USB installation media ... maybe on a different USB flash drive. Your problem could have many causes, but the first thing I'd definitely want to rule out would be bad Windows 7 installation media.

    If you used a downloaded .iso, confirm the file you got was not corrupted during download.