How can I connect a parallel port to a VMware Workstation guest on Windows 7 x64?

Discussion in 'Virtualization' started by foxyrick, Dec 29, 2011.

  1. foxyrick

    foxyrick MDL Junior Member

    Aug 25, 2011
    63
    28
    0
    Now, I have tried, for most of the day in fact. I've also searched the web without success... just a load of 'The parallel port is dead, buy a USB printer' comments, which don't help.

    My setup: Windows 7 x64 Ultimate host, XP 32-bit SP2 guest, VMware Workstation 8.0.1.

    I've configured the port in the guest's configuration, and checked for the expected entries in the config file. As far as I can tell it's all in order. It's not exactly rocket science.

    However, when I start the guest, I get the log message, 'The "LPT1" device is used by another program'. This is echoed if I right-click the LPT device icon and click 'connect'. So, Workstation won't connect the port to the guest.

    I've never used or had anything connected to the port before, so I don't know what is using it, if anything. I certainly can't see anything obvious. The port is configured correctly on the host in device manager.

    I don't know if this is a Windows 7 issue or a Workstation issue.

    I'm trying to use a couple of older device programmers that connect through that port, and they are expensive so buying new (usb) hardware is not an option. Neither are any other workarounds like net sharing the port. Oh, and the software won't run properly on Windows 7, even in compatibility mode, hence the need for XP.

    Does anyone have any ideas?

    Rick.
     
  2. sebus

    sebus MDL Guru

    Jul 23, 2008
    5,934
    1,801
    180
    And how about buying just parallel-to-usb converter ?
    They are NOT that expensive any more

    sebus
     
  3. foxyrick

    foxyrick MDL Junior Member

    Aug 25, 2011
    63
    28
    0
    Thanks, but unfortunately they have a habit of not working well (if at all) with such devices. That was a common issue when laptops stopped providing a parallel port and people tried using their microcontroller programmers with a USB-parallel adapter.
     
  4. Rainey

    Rainey MDL Novice

    Apr 27, 2011
    23
    3
    0

    You may have to disable the port in the PC's BIOS and let the VM,s BIOS take control of it (not sure it will be seen at this point). Give it a try anyways and see if it helps.
    Otherwise you may need it enabled in the PC's BIOS but stop the service in windows that is taken control of it. then i might be free for the VM.