How can I eliminat the Yahoo Search engine completely ?

Discussion in 'Windows 10' started by Nicholas440, Sep 2, 2015.

  1. Nicholas440

    Nicholas440 MDL Novice

    Oct 4, 2008
    48
    0
    0
    Ever since doing a clean install of Windows 10,and installing Firefox, I'm forever getting a Yahoo search engine when I have Google set up as my default. I remove Yahoo from Firefox lists, and it mysteriously comes back .

    Is there any way I can block the Yahoo search engine from showing up ? I removed Bing from Firefox too and it does not show up. Normally I do get Google but I'm really pissed at times when I type in a search and up pops the Yahoo engine again.


    Can I get rid of Yahoo once and for all ? I hate it....

    thank you in advance.... Nick,
     
  2. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    453
    60
    #2 odiebugs1, Sep 2, 2015
    Last edited: Sep 2, 2015
    You should delete all your history, cookies, everything, and do the same for internet option in control panel, make sure your firefox is updated 40.0.3 and set it back to the search you want and it shouldn't switch.

    Firefox- History- clear recent history- check all.

    Control panel- internet options- browsing history- delete- check all.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Nicholas440

    Nicholas440 MDL Novice

    Oct 4, 2008
    48
    0
    0
    Thank you, I did all that you suggested and installed Firefox 40.0.3 .. Yahoo came back again after about 1/2 hour. I have all history deleted, all cookies removed etc....and I"ve been looking in Firefox folders to see where they hide the search engines. If you pick Restore Default Search Engines in the Settings options it puts Yahoo, Bing, etc all back on the list so Yahoo is located somewhere in the Browswer settings and I have not seen it yet.

    Any more suggestions ? Thank you...
     
  4. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    453
    60
    #4 odiebugs1, Sep 2, 2015
    Last edited: Sep 3, 2015
    Try this, type- about:config in address, then place - " browser.search.defaultengine " in the search box, RT click modify on both strings and change to google.

    Then if it changes back.
    Note what you have for add-ons and backup bookmarks, go to Help, troubleshoot information, on RT top of page is refresh Firefox.

    If it comes back, you have a serious hijacker and should run Hitman pro 3. I would also go to Bit Defender, and run the online scanner.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Nicholas440

    Nicholas440 MDL Novice

    Oct 4, 2008
    48
    0
    0
    Thank you Odie, I did that and you're right it brought up Yahoo and Google both when I used default search engine in the Search box. So I did the Modify and put Google in where it said Yahoo. I noticed in the first step where I put in about:config that somewhere down that list it had yahoo listed twice, but also showed Google as default. Thank you again, I'll download some of your suggestions and use them to see if there is any malware on this machine. Shouldn't be because I formatted the drive and did a clean install and did very little surfing. I normall empty history and cookies anyhow so theres no tracking in there hopefully. I'll see how this works but I think you did the trick.
     
  6. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    453
    60
    Lets hope that yahoo doesn't come back, and appreciate the reply.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Mutagen

    Mutagen MDL Addicted

    Feb 18, 2013
    579
    121
    30
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...