How did this obvious bug get into Win8 RTM and still remain unfixed till this day?

Discussion in 'Windows 8' started by eydee, May 2, 2013.

  1. eydee

    eydee Guest

    Hybrid boot:
    Num lock is on at the login screen if you warm boot the computer (restart).
    Num lock is off at the login screen if you cold boot the computer (turn on from unpowered state).
    Registry setting is ignored.

    Normal boot:
    Num lock is always on at the login screen no matter if you restart or cold boot. Registry setting is respected. This is what matches previous Windows versions' behavior.
     
  2. panchop

    panchop MDL Member

    Jul 26, 2009
    127
    65
    10
    if you suspend or hibernate windows 8 what hapens?
     
  3. ljimbo

    ljimbo MDL Novice

    Mar 10, 2010
    47
    11
    0
    This is something that annoys the crap out of me.. i use the pin code to login.. my password is an ass to type :p.. doesnt matter what boot cold/hybernate/sleep/warm whatever my Numberlock key is always off..

    i figured it had something to do with Logitech drivers tho.
     
  4. eydee

    eydee Guest

    Then it's something completely different. The issue I'm talking about happens with all normal, mortal keyboards which require (and have) no additional drivers.

    @panchop:
    No idea, and I have no access to the win8 computer for a few days. However, I think what you're asking is not really relevant. The big question is: Why is hybrid and normal boot different when it comes to reaching the login screen?
     
  5. docdocdoc9

    docdocdoc9 MDL Novice

    Feb 25, 2008
    42
    62
    0
    Nice, I thought it was just me / my motherboard.
    Very annoying when you use a passcode as your login... I hope they get that fixed soon or at least a workaround is found.
    Thing is it may actually be a problem on the UEFI side - in hybrid boot many initialization functions are being bypassed including keyboard initialization.
     
  6. ljimbo

    ljimbo MDL Novice

    Mar 10, 2010
    47
    11
    0
    It could be the same problem.. infact it probably is related to the UEFI mentioned by docdocdoc9 above... im not sure it has anything to do with logitech drivers i just thought it might have been ;) but if loads of other people are having it maybe its not ;).. i thought it was those drivers and never bother to look into it more as the logitech drivers at the time were a little buggy with remembering macros and using the LCD display correctly.
     
  7. Rainey

    Rainey MDL Novice

    Apr 27, 2011
    23
    3
    0
    I don't seem to have a problem with this once i turned it on with the following

    Num Lock keep turning off


    1. Go to start and type regedit.exe.
    2. Navigate to HKEY_USERS\.Default\Control Panel\Keyboard.
    3. You'll see an entry on the right called InitialKeyboardIndicators. The "usual" default value is 0. Double click on this entry and change the value to 2.
    4. Close registry editor.
     
  8. ljimbo

    ljimbo MDL Novice

    Mar 10, 2010
    47
    11
    0
    #8 ljimbo, May 6, 2013
    Last edited: May 6, 2013
    my default setting was 2147483648.. set it to 2 shut down and restarted .. still no Numberlock on ;)

    /edit

    after some research there doesnt appear to be a way to enable it BEFORE putting in the pin pass... even using a logon script to send a NumLock keypress doesnt happen till after login.

    however you can get it to work via the registry setting IF you disable Fastboot... (which im not going to to)...
     
  9. valium10

    valium10 MDL Novice

    Mar 31, 2013
    3
    0
    0
    Another obvious bug in Windows 8 is the 'Disk Error 135' randomly. Mostly affected by SSD users. Even Enabling Hyper-V, bcdedit fix won't resolve the issue.
     
  10. eydee

    eydee Guest

    Additional information: I have an older motherboard with no UEFI support, so it cannot be an UEFI problem. The registry setting mentioned above is the one I mentioned in the OP. Completely ignored unless hybrid boot is turned off.
     
  11. coleoptere2007

    coleoptere2007 MDL Guru

    Apr 8, 2008
    2,288
    1,176
    90
    #11 coleoptere2007, May 8, 2013
    Last edited: May 8, 2013
    Concerning the Num Lock off or on, I made a lot of installations on differents HHDs, sometimes it's on or off, even if it is active in BIOS or with registry modifications. This is a randomly problem :confused: with Windows 8 and never had it on Windows 7 versions.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. panchop

    panchop MDL Member

    Jul 26, 2009
    127
    65
    10
    Sorry the question but, it's too dificult for you press the numlock key?
     
  13. coleoptere2007

    coleoptere2007 MDL Guru

    Apr 8, 2008
    2,288
    1,176
    90
    Not for me, but it seems to be a problem for other users. I just answered it's a randomly problem.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. murphy78

    murphy78 MDL DISM Enthusiast

    Nov 18, 2012
    6,674
    10,073
    210
    If you never completely shutdown, it will never initialize the registry. Disabling fast-boot is the only way to do a registry mod and have it actually do something..
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. eydee

    eydee Guest

    Considering how many times a user logs in during the lifetime of an OS, yes it is. Just imagine that it was Windows XP doing this. So many people pressing the key for more than 10 years every day or even more often... That's millions of unnecessary keystrokes in the world, maybe even more than that. The only winners here are the keyboard manufacturers, how will certainly sell more products because of dead keys. Considering how many people use laptops these days where replacing the keyboard is not a trivial thing and costs a lot, it's tons of money thrown out of the windows because of a little stupid bug.