How disable IDE controller (Secondary Master) in MS VPC 2007?

Discussion in 'Virtualization' started by Gelip, Oct 4, 2015.

  1. Gelip

    Gelip MDL Novice

    Feb 28, 2011
    42
    2
    0
    #1 Gelip, Oct 4, 2015
    Last edited: Oct 5, 2015
    MS VirtualPC 2007 there is no way to disable CD-ROM drive. CMOS settings for the virtual machine in the file .vmc:
    vmc_cmos.png
    Is it possible to somehow disable the second IDE controller so that did not work CD-ROM drive?

    I tried the program CMOSER but probably not working:
    cmoser.png
     
  2. Gelip

    Gelip MDL Novice

    Feb 28, 2011
    42
    2
    0
    #2 Gelip, Oct 5, 2015
    Last edited by a moderator: Apr 20, 2017
    (OP)
    I found the solution :)
    You have to enter incorrect absolute string in the IDE controller ID 1, location 0 in the file .vmc eg. a few small letters. In the example I used the word "dummy" and close tag </absolute>:
    Code:
    <ide_controller id="1">
        <location id="0">
            <drive_type type="integer">2</drive_type>
            <pathname>
                <absolute type="string">dummy</absolute>
                <relative type="string" />
            </pathname>
        </location>
    </ide_controller>
    Tested in MS VirtualPC 2007 for x64 - 6.0.192.0

    Please test other version MS VPC and report.
    Thx.
     
  3. Gelip

    Gelip MDL Novice

    Feb 28, 2011
    42
    2
    0
    #3 Gelip, Apr 28, 2016
    Last edited by a moderator: Apr 20, 2017
    (OP)
    If you edit a .vmc file while stored in the NVRAM settings for Secondary Master Channel you may receive an error:
    Code:
    Secondary Channel (0) Drive - ATAPI Incompatible
    Press F1 to Run SETUP
    Press F2 to load default values and continue
    You have to press F2 to load default settings.