How do I change the Current User Display Language ??

Discussion in 'Windows 10' started by pgriffith, Sep 4, 2015.

  1. pgriffith

    pgriffith MDL Novice

    Aug 7, 2007
    3
    1
    0
    Hi everyone

    I can't seem to change the Current User Display Language.

    ie look here i.imgur.com/3tAEn3J.jpg

    I want to be able to set everything to English (Australia)

    Can't seem to do it in final or latest Insider build.

    Australia is now supported for Cortana, but with EVERYTHING set to English (Australia) she still says I'm not in a supported region and I think it's because of the Display Language.

    I've got a Reddit thread going here as well
    reddit.com/r/Windows10/comments/3jhorm/how_do_i_change_the_current_user_display_language/

    Sorry about the URL's, I don't have enough posts to include links yet.

    So any ideas ??
     
  2. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    457
    60
    #2 odiebugs1, Sep 4, 2015
    Last edited: Sep 4, 2015
    Control panel- region

    Settings-time language-region an language- display language
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. pgriffith

    pgriffith MDL Novice

    Aug 7, 2007
    3
    1
    0
    You clearly missed the part where I said ..... EVERYTHING set to English (Australia) :)

    I KNOW where all the setting are, but I can't change the current display language.
     
  4. xinso

    xinso MDL Guru

    Mar 5, 2009
    4,242
    5,511
    150
    #4 xinso, Sep 5, 2015
    Last edited by a moderator: Apr 20, 2017
    Now I am on a fresh en-US 10240 Pro x64 (because you are using this language).

    1. Go to Control Panel\Clock, Language, and Region\Language

    2. Add a language > English > English (Australia)

    3. Move up English (Australia) > Remove English (United States) > Options > Download and install language pack > Close

    4. Run Command Prompt (Admin) > Input regedit and press Enter

    5. Browse to HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\MUI\PreinstalledLanguages

    6. Rename en-US as en-GB (if both are present, delete en-US) - set en-GB as System language

    7. Restart

    8. (Optional) Run Command prompt (Admin) > Input the following command and press Enter - to uninstall en-US language pack > Input Y to restart

    Code:
    C:\windows\system32>dism /online /remove-package /packagename:Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~amd64~en-US~10.0.10240.16384
    9. Settings > Time & language > Reginal & language > English (Australia) > Options > Install Handwriting and Speech

    10. Control Panel > Change date, time , or number formats > Set everything to English (Australia)

    11. Restart

    Good luck!

    [Note]

    1. If en-US language pack was not removed, please set English (Australia) as the primary language as follows:

    Goto Control Panel\Clock, Language and Region\Language > English (Australia > Options > Make this the primary language.

    2. Since English (Australia) uses en-GB language pack, why not use en-GB version as your OS.

    3. I have set everything to English (Australia), but the Cortana would not work. But, I can use Cortana if everything set to en-US/en-GB.
     
  5. Hadron-Curious

    Hadron-Curious MDL Guru

    Jul 4, 2014
    3,532
    519
    120
    I would suggest you go to the same Settings and install additional language, like GB English and change the display language. You can revert back to Australian English after observing positive effect.
     
  6. xinso

    xinso MDL Guru

    Mar 5, 2009
    4,242
    5,511
    150
    #6 xinso, Sep 5, 2015
    Last edited: Sep 6, 2015
    On 10240, it works with these settings:

    Windows display language: English (Australia)

    Format: English (Australia)

    Home location: United kingdom

    Current language for non-Unicode programs: English (Australia)

    Cortana-OZ.png
     
  7. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    457
    60
    #7 odiebugs1, Sep 5, 2015
    Last edited: Sep 5, 2015
    Then don't post what you posted above, and how can it be set to Australia, when the pic you posted doesn't show Australia, it shows UK.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. xinso

    xinso MDL Guru

    Mar 5, 2009
    4,242
    5,511
    150
    #8 xinso, Sep 6, 2015
    Last edited by a moderator: Apr 20, 2017
    I have only zh-TW 10532 Pro x64. Here is how I made it to get Australian Cortana:

    1. Add English (Australia) > Download and install language pack - It will install en-GB instead, NOT en-US.

    2. Remove Chinese (Traditional)

    3. Check/Modify the registry as follows to set preinstalled language from zh-TW to en-GB

    Code:
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\MUI\PreinstalledLanguages\en-GB]
    Code:
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\MUI\UILanguages\en-GB]
    "DefaultFallback"="en-US"
    "en-US"=hex(7):00,00,00,00
    "LCID"=dword:00000809
    "Type"=dword:00000112
    Code:
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Nls\Language]
    "InstallLanguage"="0809"
    "Default"="0c09"
    "InstallLanguageFallback"=hex(7):65,00,6e,00,2d,00,55,00,53,00,00,00,00,00
    Code:
    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Nls\Locale]
    @="00000809"
    "(Default)"="00000c09"
    3. Restart

    4. Uninstall zh-TW language pack by

    Code:
    lpksetup /u
    5. Set everything to English (Australia)

    Windows display language: English (Australia)

    Format: English (Australia)

    Home location: Australia

    Current language for non-Unicode programs: English (Australia)

    6 Settings > TIME & LANGUAGE > Region & language > English (Australia) Windows display language > Options > Install handwriting and speech

    7. Restart

    Enjoy!

    [Note]
    I do not have en-GB edition, or I would test it for you. Sorry about that.
     
  9. spidernz

    spidernz MDL Senior Member

    May 20, 2011
    279
    71
    10
    #9 spidernz, Sep 6, 2015
    Last edited: Sep 6, 2015
    Via DISM it's like this

    Dism.exe" /Image:%MOUNT% /Set-UILang:en-NZ
    Dism.exe" /Image:%MOUNT% /Set-UILangFallback:en-US
    Dism.exe" /Image:%MOUNT% /Set-Syslocale:en-NZ
    Dism.exe" /Image:%MOUNT% /Set-UserLocale:en-NZ
    Dism.exe" /Image:%MOUNT% /Set-InputLocale:1409:00000409
    Dism.exe" /Image:%MOUNT% /Set-TimeZone:"New Zealand Standard Time"
    Dism.exe" /Image:%MOUNT% /Get-Intl


    edit: Nvm re-read question.