How do i enable "Always ask me before opening file"

Discussion in 'Windows 7' started by HelpMe, Feb 22, 2010.

  1. HelpMe

    HelpMe MDL Junior Member

    Jul 30, 2009
    90
    7
    0
    Hi, i uncheck marked that option "Always ask me before opening a file", but i want to put it back on, how would i do this? This is on a windows 7 Home edition. TIA.
     
  2. venu

    venu MDL Addicted

    Oct 16, 2009
    894
    99
    30
    Paste the following text in "Run" command box (Win key + R) and hit enter

    reg delete hkcu\software\microsoft\windows\shell\attachmentexecute\{0002df01-0000-0000-c000-000000000046} /va /f
     
  3. HelpMe

    HelpMe MDL Junior Member

    Jul 30, 2009
    90
    7
    0
    Thx for the response, i tried what you said, however when i try to run the program that i unchecked in the first place, it still runs without that pop up message, however it works for the other programs that i try to run that i never unchecked for.
     
  4. venu

    venu MDL Addicted

    Oct 16, 2009
    894
    99
    30
    What program did you uncheck?
     
  5. HelpMe

    HelpMe MDL Junior Member

    Jul 30, 2009
    90
    7
    0
    It was this program "Opera_1050_en_b1_Setup", i know it is a safe program, however after i unchecked marked the "Always ask to open file", when i tried running other programs the popup message didn't come up any more, but after ran that command line, when i tried to run "Opera_1050_en_b1_Setup" again, i didn't get no popup message asking if i wanted to run the file, however when i try to run my other apps, i do get the popup message.

    By the way, what does the /va /f mean?

    reg delete hkcu\software\microsoft\windows\shell\attachmentex ecute\{0002df01-0000-0000-c000-000000000046} /va /f
     
  6. venu

    venu MDL Addicted

    Oct 16, 2009
    894
    99
    30
    That command is meant to reset the Always ask for before opening this type of file for ALL file types.
    /va means delete all values under this key.
    /f means force deletion without prompt.
    The security warning is meant to protect you from unsafe attachments. Try running another safe exe file and see whether you get a prompt or not.
     
  7. Phazor

    Phazor MDL Expert

    Sep 1, 2009
    1,145
    517
    60
    #7 Phazor, Feb 22, 2010
    Last edited by a moderator: Apr 20, 2017
    Since the command was posted without code tags it ended up with a space in 'attachmentexecute'.

    It has to be removed, like here:

    Code:
    reg delete hkcu\software\microsoft\windows\shell\attachmentexecute\{0002df01-0000-0000-c000-000000000046} /va /f
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. venu

    venu MDL Addicted

    Oct 16, 2009
    894
    99
    30
    #8 venu, Feb 22, 2010
    Last edited by a moderator: Apr 20, 2017
    oops...my bad.
     
  9. HelpMe

    HelpMe MDL Junior Member

    Jul 30, 2009
    90
    7
    0
    well i just tried both codes and when i try to open the opera file, it just starts to load up and install, however with other files, i am getting the prompt whether to run the program or not.
     
  10. greyaburton

    greyaburton MDL Addicted

    Mar 8, 2009
    556
    53
    30
    try checking your autoplay options.in control panel click autoplay.look for software and games.make sure ask me everytime is selected.click save.dont know though if it will fix your problem though.good luck.
     
  11. wsatis

    wsatis MDL Novice

    Nov 14, 2010
    1
    0
    0
    i gon't have the "attachmentexecute" in my shell file - what do i do