How to enable AHCI in Windows 10?

Discussion in 'Windows 10' started by ultimate_live, Dec 26, 2015.

  1. ultimate_live

    ultimate_live MDL Addicted

    Mar 15, 2011
    771
    627
    30
    I installed Windows 10 on a brand new SSD Crucial. But I checked that the SSD is running in IDE mode. I changed it in BIOS to AHCI but after restarting I got the message ' inaccessible_boot_device'. So I turned back to IDE and worked well.

    So after reading for a time I read that changing the registry and enabling AHCI it would work. But didn´t.
    I made the following changes:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV
    Changed item "Start" to 0. (it was still in '0')

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV\StartOverride
    Changed item "StartOverride" to 0. (changed from '3' to '0')

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci
    Changed item "Start" to 0. (it was still in '0')

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\StartOverride
    Changed item "StartOverride" to 0. (changed from '3' to '0')

    After the changes I enabled AHCI in Bios and still the same message: ' inaccessible_boot_device'.
    What may be wrong?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. ashmicro

    ashmicro MDL Junior Member

    Mar 2, 2012
    87
    7
    0
    You need to have it in AHCI mode before you install Windows. Just wipe it and do it again. I can't imagine it'll take very long.
     
  3. Mutagen

    Mutagen MDL Addicted

    Feb 18, 2013
    579
    122
    30
    I don't think you can convert it - my guess is a fresh installation, after setting the bios to AHCI, is the only option.

    How was WIN10 installed? Upgrade or clean?

    How about some details about the computer - laptop, desktop, latest bios, etc. With all due respect, it appears you have enough experience to know you would be asked about this. Good luck!
     
  4. ultimate_live

    ultimate_live MDL Addicted

    Mar 15, 2011
    771
    627
    30
    It seems it will take a couple of hours to install and configure everything again.

    Windows 10 clean install, Desktop with latest Bios.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. A pinch of experience is worth a peck of theory.

    GPT or MBR?
    Mainboard, Controller, Chipset ?

    To get it right: bootxxx.dat
    V A L I D A T E _ S D - V a l i d a t e S D S S t r e a m
    V A L I D A T E _ S D - S c a n M f t
     
  6. mimart7

    mimart7 MDL Senior Member

    Aug 28, 2012
    331
    84
    10
    So long as you have the latest drivers, software installed, you should clone or image hard drive. If you need to do a fresh install, you will have a backup, that will most likely take under 10 minutes to restore.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. dhjohns

    dhjohns MDL Guru

    Sep 5, 2013
    3,276
    1,731
    120
    Restart in safe mode first.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. chris34

    chris34 MDL Member

    Oct 28, 2009
    188
    49
    10
    #8 chris34, Dec 26, 2015
    Last edited by a moderator: Apr 20, 2017
    You need to reboot in safe mode after you enable AHCI in the bios. Force safe mode menu/boot in msconfig, reboot to the bios, then when you have changed the SATA mode to AHCI reboot in Safe mode and let windows do the switch to the new SATA interface. When it's done just reboot to windows and use the AHCI drivers that come with Windows or update to the latest manufacturer's drivers.


    Dunno about the newer Crucial drives, but if you have a MX100 disable the LPM mode in the SATA options if you use an intel chipset. On the Mx100 if you don't disable it, the drive randomly freeze/BSOD even with the mu02 firmware

    If you don't use the drivers UI, the registry entries to disable it are:
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorA\Parameters\Device]
    "Controller0Phy0HIPM"=dword:00000000
    "Controller0Phy0DIPM"=dword:00000000
    "Controller0Phy1HIPM"=dword:00000000
    "Controller0Phy1DIPM"=dword:00000000
    "Controller0Phy2HIPM"=dword:00000000
    "Controller0Phy2DIPM"=dword:00000000
     
  9. scaramonga

    scaramonga MDL Member

    Oct 27, 2012
    172
    80
    10
    I'd be after a new PC then. A couple of hours? lol :g:
     
  10. Bezalel

    Bezalel MDL Member

    Apr 30, 2012
    230
    23
    10
    Running Repair from a UFD/DVD should fix the boot entries.
     
  11. chris34

    chris34 MDL Member

    Oct 28, 2009
    188
    49
    10
    You don't need to repair or reinstall when you change the interface from IDE to AHCI or vice-versa, you just need to reboot in safe mode for windows to load the new interface/drivers.
     
  12. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,318
    120
    Just enable the AHCI in bios, than boot whith hiren's boot CD, and from the utilities launch the FIXHDC.cmd.

    Then reboot normally.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

  13. h ttp://windowsten.info/filedata/fetch?id=6018&d=1421784783

    h ttps://ww w.virustotal.com/de/file/551886804fd55a4b795cc2e465e8199bc798f71d5fda79f3c3ad853ca14c31cd/analysis/1451216512/

    h ttp://windowsten.info/tutorials/5770-fix-windows-wont-boot-after-changing-hardware
     
  14. mwnn

    mwnn MDL Novice

    Mar 29, 2013
    12
    4
    0
    #14 mwnn, Dec 27, 2015
    Last edited by a moderator: Apr 20, 2017
    Made the same mistake myself after resetting my BIOS to defaults.

    As stated above - no fancy tricks needed:

    Code:
    Admin Command Prompt
    bcdedit /set {current} safeboot minimal
    
    • Reboot and then enter the BIOS (typically press F1, F2, F10 or Delete)
    • Change the SATA drive setting to AHCI and exit the BIOS save settings.
    • Windows will boot into Safe Mode.
    • Open an Administrator Command Prompt again and enter the following command to disable Safe Mode boot:
    Code:
    bcdedit /deletevalue {current} safeboot
    • Reboot

    Or just go through msconfig and check/uncheck safe boot under Boot Tab.
     
  15. ultimate_live

    ultimate_live MDL Addicted

    Mar 15, 2011
    771
    627
    30
    Problem solved.
    I changed the values in registry, restarted and changed from IDE to AHCI in Bios. There I got the message that the Boot Device wasn´t accessible.
    changed again to IDE and worked again. Then I started Windows in Safe mode, but before starting in safe mode I changed from IDE to AHCI again and worked.
    Restarted Windows in normal mode and no issues. Windows started normally and now running in AHCI instead of IDE.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...