How to install Mint that comes with an incompatible generic GPU driver.

Discussion in 'Linux' started by Yen, Nov 1, 2016.

  1. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,209
    11,003
    340
    Some users which want to install Linux mint encounter a black screen during running of the Linux CD and cannot install it out of the box.

    This affects mostly newer Nvidia GPUs.

    How to go:
    Boot live from the Mint CD/USB.

    In MBR boot mode a screen appears: automatic boot in 10,9,8..seconds.

    Press any key to show the menu.
    Press TAB to edit the first line (Start Linux mint)
    Replace quiet splash with nomodeset and hit enter.

    In EFI mode the screen looks different.

    Press E to edit the first line (Start Linux Mint *Edition*)
    Replace quiet splash with nomodeset and hit enter.

    You should now be able to install Mint on your PC.

    After the installation, reboot the computer and hold SHIFT to force the boot menu to appear.
    Press E to edit the first line of the boot menu. (The first line is your Mint version to be run).
    Find the line containing quiet splash.
    Replace quiet splash with nomodeset
    Press CTRL-x or F10 to boot.

    If your graphics card is from NVIDIA, once in Linux Mint, perform the following steps to install the NVIDIA drivers:
    Run the Driver Manager
    Choose the NVIDIA drivers and wait for them to be installed
    Reboot the computer
    If you want to have a list with more recent drivers to choose read post #2

    With these drivers the system should now be stable and you no longer need to use "nomodeset"

    Note: If you still cannot boot try one of the following solutions:

    -Try with "nouveau.noaccel=1" instead of "nomodeset".
    -Use the "Compatibility mode" to boot and install Linux Mint.
    -After the installation, use "Advanced Options" -> "Recovery mode" from the boot menu and choose "resume".

    These instructions are from the official Mint site and helped me to install Mint using a Nvidia GTX970. :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,209
    11,003
    340
    The default software sources manager does not offer recent drivers for your GPU, how to get them?

    Open the System Settings program and then click Software Sources from the Administration section.

    After this, click the PPAs option on the left-side and then click the Add a New PPA button. In the text box, type in ppa:graphics-drivers/ppa. Then click the Ok button followed by Update the cache.
    Close it.

    When you now open your driver manager you should get a list with recent drivers.
    Check which driver is the most recent for your GPU at your GPU vendor site, then go back to the driver manager and install it from there. Always check which one is the latest for your hardware on the vendor site first to avoid to install one that is probably not running. I have just updated to the latest that runs a GTX970.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Superfly

    Superfly MDL Expert

    Jan 12, 2010
    1,133
    542
    60
    Nice... so no need to avoid Nvidia any longer...

    BTW just ordered my son a GTX 1060...will see how it behaves with Linux drivers - altho' I thought the newer kernels had these covered? :eek:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. sl1fka

    sl1fka MDL Novice

    Jan 1, 2016
    41
    29
    0
    Exactement!

    I thought only AMD GPU's were affected by this.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,209
    11,003
    340
    After you've added that PPA from my previous post it offers driver 367.57, this one works completely with kernel 4.2 (crypto login screen also visible).....it's the latest for GTX970 and 1060

    I had to resolve 2 issues installing mint 17.3....the original kernel has issues (bad response when pushing buttons, ACPI related error on boot up) and the default generic GPU driver live boots to a blank screen using GTX970, with a 470 it has worked.

    Not sure what's with 18.0....
    I booted live with nomodeset, installed mint.....then I updated kernel to 4.2 and to the latest driver available at default sources...finally I could install the latest 367.57 by adding PPA....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Maitopurkki

    Maitopurkki MDL Novice

    Feb 17, 2018
    8
    1
    0
    Isn't there already ready driver? Just go to driver management and choose right ones
     
  7. free1975yuly

    free1975yuly MDL Expert

    Aug 24, 2011
    1,773
    151
    60
    I'm wondering if these solution can be applied to another Linux Distro like Manjaro; that I had issues with!
     
  8. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,209
    11,003
    340
    Well in the end its about to boot the kernel with 'nomodeset' or 'xforcevesa' to make it use a native mode..it's all about grub2 which allows to boot Linux with different kernel parameters by editing the config and updating grub2. Changes can either be applied temporarily until the reason has been eliminated or permanently to have different kernel parameters at each boot.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. free1975yuly

    free1975yuly MDL Expert

    Aug 24, 2011
    1,773
    151
    60
    Those above procedures does not work on my machine. Tried them multiple times...
     
  10. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,209
    11,003
    340
    #10 Yen, Mar 21, 2018
    Last edited: Mar 21, 2018
    (OP)
    Do you still refer to another distro like Manjaro?

    You could try to add pci=norcs. (and if it's not working pci=realloc additionally or alone)
    For a one time edit you can press “e” when you select the Grub menu entry and go with the cursor to the end of the line which starts with “linux” and enter pci=norcs there.

    Another parameter alone would be acpi=off nomodeset


    Have you really got a blank screen (no display at all)..? Or is there a (blinking) cursor left?

    Could you get into terminal somehow?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. free1975yuly

    free1975yuly MDL Expert

    Aug 24, 2011
    1,773
    151
    60
    NOPE .The installations allways stuck at mhwd...busy timeout or this kind of stuff... and if I choose to install with non-free drivers my laptop coolers work at 100% and the machine is blocked..