How to install Windows 8 EFI on Asus Bios

Discussion in 'Windows 8' started by deusdead, Jul 27, 2013.

  1. deusdead

    deusdead MDL Novice

    Dec 22, 2011
    11
    2
    0
    Hello everyone

    I wanted to change my windows 8 single language version for the professional x64 one, but i cant make it boot in UEFI
    It can be installed enabling CSM, But it doesn't install as EFI, just as MRB, im using a DVD.
    I tried to do this.

    My DVD already have this path "\EFI\BOOT\BOOTX64.EFI" But when i launch the EFI shell i only found this file "BOOTIA32.EFI" But when i check the DVD data that file is nowhere, Maybe i failed at burning the W8 Iso?
    or i need to test with another one?

    Please Excuse my English.
    Thanks.

    *Added some photos.
     

    Attached Files:

  2. Shenj

    Shenj MDL Expert

    Aug 12, 2010
    1,557
    652
    60
    #2 Shenj, Jul 27, 2013
    Last edited by a moderator: Apr 20, 2017
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. deusdead

    deusdead MDL Novice

    Dec 22, 2011
    11
    2
    0
    #3 deusdead, Jul 28, 2013
    Last edited by a moderator: Apr 20, 2017
    (OP)
    Thanks for your help.
    I tryed but doest work, oscdimg closes intermediately, so i open cmd as administrator and type all the code ( executing oscdimg of course ), but "Error 5: Access is denied, i have tried too with command prompt but doesn't work, look.

    Capturej.PNG

    I typed all the command manually, and the paths are the same.

    Capture32.PNG

    What can i do, of course excuse my insistence :)
    *Edit, Also tried using the administrator account, (net user administrator /active:yes )but the same error appears
    Also edited the folders permissions to full control, doesn't work too.*
     
  4. Shenj

    Shenj MDL Expert

    Aug 12, 2010
    1,557
    652
    60
    #4 Shenj, Jul 28, 2013
    Last edited by a moderator: Apr 20, 2017
    You do not need elevation(admin) for this.

    Looking at your screenshot, you are making a error, you are not supposed to "oscdimg.exe oscdimg".

    Code:
    C:\oscdimg.exe -m -o -u2 –udfver102 -bootdata:2#p0,e,bC:\files\boot\etfsboot.com#pEF,e,bC:\files\efi\microsoft\boot\efisys.bin C:\files C:\ISO\Win8.iso
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. FaiKee

    FaiKee Misinformation spreader

    Jul 24, 2009
    4,305
    5,796
    150
  6. deusdead

    deusdead MDL Novice

    Dec 22, 2011
    11
    2
    0
    #6 deusdead, Jul 28, 2013
    Last edited by a moderator: Apr 20, 2017
    (OP)
    As you said, was my fault! :DD! now it worked, in a few mins i will burn it and try to install again :D!
    Thank you so much for looking into this problem :D!
    Divines bless you. May the ground you walk quake as you pass u_u

    Ill report the results later. :)
     
  7. deusdead

    deusdead MDL Novice

    Dec 22, 2011
    11
    2
    0
    As soon I burn the dvd i will Check that, thanks :D
     
  8. deusdead

    deusdead MDL Novice

    Dec 22, 2011
    11
    2
    0
    Thanks :)

    Hello again

    As i said this is the report.

    After the process with oscdimg, i ended with an ISO of 5,02 GB, i couldn't find a Double Layer Disc at that hour, so i found a 8 GB USB stick, And Tried to use Rufus, but for EFI its a must FAT 32 and FAT 32 has a limit of 4 GB ISO.

    So i was stuck, later i found another ISO a 3,29 GB one, Great! used Rufus and worked like charm, I didn't have problems again with the UEFI Boot, in the moment i plugged the USB stick and reboot, the EFI loaded the Windows Installer instantly, Clicked Next but!
    a wild " The product key entered does not match any of the Windows images available for installation. Enter a different product key." appears so i canceled the installation, plugged the USB stick in other PC, and added this file created in Notepad.

    [EditionID]
    [Channel]
    Retail
    [VL]
    0

    Saving it as ei.cfg in the Sources Folder of the Windows in the USB stick, Tried Again and Installed Without any problem and loaded as EFI.

    Thanks So much for your help! Hope this can help another people \(^w^)/

    Captura.PNG