How to replace the PSA diagnostic utility

Discussion in 'BIOS Mods' started by badboy1985ro, Feb 19, 2010.

  1. badboy1985ro

    badboy1985ro MDL Novice

    Sep 4, 2009
    6
    0
    0
    Thanks to the guys on this forum i manage to install windows 7 ultimate and activate it after downloading the A17 bios with slic 2.1 from this forum
    Know i have a new challenge ahead.
    Dell bios A17 has a onboard diagnostic program called PSA+
    Basically this utility is somewhere in the flash and i don't the size or how to replace it.
    I would like to know if there is away to access the diagnostic partition on the motherboard to replace the software with something else (acronis lice cd ). for ex.
    I have read that is diagnostic utility is build into the bios but i have a felling that the bios actualy hides this partition or what ever it is . Is there a way to mode the bios so i can replace the diag app with something else?
     
  2. gabiz_ro

    gabiz_ro MDL Member

    Feb 2, 2010
    170
    12
    10
    Don't know your particular case but on my Inspiron after running few tests diagnostic utility tell me no partition found,press ok to restart.
    PSA is in bios.one of the bigger module.
    As for replacing with something else,I'm interested too but until now I have no clue.
    Anyway in startup sequence there is a split somewhere and from that point you can choose to continue normal startup or to load PSA part and diagnose system.
     
  3. badboy1985ro

    badboy1985ro MDL Novice

    Sep 4, 2009
    6
    0
    0
    Thanks but you are not being very helpfully
     
  4. badboy1985ro

    badboy1985ro MDL Novice

    Sep 4, 2009
    6
    0
    0
    gabiz_ro i don't understand.
    What do you mean when booting to diag mode no partition found?
    The diag utility is not installed on the hdd, it is in flash. I have upgraded my hdd from 120 gb to 500 gb and works fine. No errors are displayed when performing the diag tests and i have a inspiron 6400.
     
  5. gabiz_ro

    gabiz_ro MDL Member

    Feb 2, 2010
    170
    12
    10
    When I select at startup diagnose test they run until the end,no errors but at the end is a message something about partition not found press ok to restart if I remember correct.
    Is not clear for me what you want to do.
    I told you already PSA is in bios.one of the bigger module.
    You want to replace software from bios or hidden partition?
    If you change hdd you have no partition then. (except case you backup this partition from initial hdd and restore to new hdd)
    These diagnostics utility is in bios.Just remove your hdd and see if it still works,if yes is in bios if not then is on hdd.
     
  6. badboy1985ro

    badboy1985ro MDL Novice

    Sep 4, 2009
    6
    0
    0
    My inspiron 6400 never had a hidden partition. When i bot it it came with free dos on a dvd and no OS installed.

    What i am truing to do is decompress the dell bios and replace the psa module with something else.

    Is there a tutorial around here where i can see what tools to use and gow to use them?
     
  7. gabiz_ro

    gabiz_ro MDL Member

    Feb 2, 2010
    170
    12
    10
    What are you planning to put in place of PSA?
     
  8. badboy1985ro

    badboy1985ro MDL Novice

    Sep 4, 2009
    6
    0
    0
    If you would have read everything you would have understood that i was refering to the partition on the eeprom where the diag is stored. and i also written in my post that i would prefer acronis live cd instead of diag tools