How to restore native m2ts playback?

Discussion in 'Windows 7' started by nfshp253, Aug 31, 2009.

  1. nfshp253

    nfshp253 MDL Junior Member

    Aug 13, 2009
    89
    0
    0
    Hello, I had installed K-Lite Codec Pack some weeks ago. After some while, I uninstalled it and instead installed Windows 7 Codecs. I then tried to play a 1080p m2ts file in Windows Media Center and it lagged horribly. I went to the Windows 7 Codecs forum to get help and the author told me that Windows 7 natively supported m2ts playback and I had to do a complete reinstall of the OS to get it back. The file plays perfectly well on Windows XP, on my other partition in the hard drive.
     
  2. Brandrune

    Brandrune MDL Addicted

    Jul 30, 2009
    528
    4
    30
    I don't really understand the question. Can you explain a bit more what you want to do?
     
  3. nfshp253

    nfshp253 MDL Junior Member

    Aug 13, 2009
    89
    0
    0
    I want to be able to use Microsoft's Build-in codec to decode and play a m2ts file smoothly because according to shark007 forums, install Haali will break the functionality.
     
  4. ammarman

    ammarman MDL Member

    Jul 17, 2009
    127
    13
    10
    I have a similar issue but with mov files, I have no sound when playing an mov :(
     
  5. nfshp253

    nfshp253 MDL Junior Member

    Aug 13, 2009
    89
    0
    0
    Can anyone figure out how to restore the functionality? Seems like a stupid Windows 7 bug!
     
  6. Opa

    Opa MDL Addicted

    Jul 29, 2009
    679
    969
    30