Howto Shadow Session w/RDP Multiuser?

Discussion in 'Windows 8' started by theonetrueace, Mar 10, 2014.

  1. theonetrueace

    theonetrueace MDL Novice

    Jan 28, 2013
    9
    5
    0
    So many thanks to everyone involved to the original version of this hack for previous versions of windows, and a special thanks to those who put in the time to bring it to windows 8.1 pro. I have it working but I can't figure out how to shadow a session. Does anyone know how? The option isn't there when I right click on the session under users tab in task manager; where it was in 7. Thanks in advance!
     
  2. theonetrueace

    theonetrueace MDL Novice

    Jan 28, 2013
    9
    5
    0
    Found it...if anyone is looking....

    mstsc /shadow:<sessionid> /control /noConsentPrompt

    So now I've got to figure out how to get around this error: The Group Policy setting is configured to require the user's consent. Verify the configuration of the policy setting.

    The GP editor won't let me in because I'm not on a domain user account, so I guess the setting is in the registry somewhere. Any ideas?
     
  3. theonetrueace

    theonetrueace MDL Novice

    Jan 28, 2013
    9
    5
    0
    Continuing down the rabbit hole...

    The following site has been somewhat helpful: etutorials.org/Microsoft+Products/microsoft+windows+server+2003+terminal+services/Chapter+6+Registry/Registry+Keys+for+Terminal+Services/

    I set fInheritShadow = 0 and Shadow = 2, but no change. It allows me to shadow through the cmd above but asks for permission.

    Stuck again....
     
  4. theonetrueace

    theonetrueace MDL Novice

    Jan 28, 2013
    9
    5
    0
    Well I'm an idiot.... Local Group Policy Editor -> Comp Config/Admin Templates/Win Comp/Remote Desktop Services/Remote Desktop Session Host/Connections/Set rules for remote control of Remote Desktop Services user sessions = Enabled:Full Control w/o user's permission

    Also figured out how to get session ids... CMD->"query session"

    Hope this info helps someone...