IE8 x64 default browser

Discussion in 'Windows 7' started by tistou77, Sep 17, 2010.

  1. tistou77

    tistou77 MDL Expert

    Mar 22, 2008
    1,285
    449
    60
    Hi

    I'd like to know if it's possible to have IE x64 default browser on win 7?
    and if so, how?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. tistou77

    tistou77 MDL Expert

    Mar 22, 2008
    1,285
    449
    60
    ok, I thought it was possible to change something in regedit (like WMP12)

    thank you ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. blero

    blero MDL Novice

    Oct 23, 2009
    24
    3
    0
    Possible ! Here's how:

    - click on Start, Default Programs.
    - click on "Associate a file type or protocol...".
    - click on "Current default parameters" (or something like that) column header, to sort the list.
    - find the items where Internet Explorer is set as default (11 items in my system).
    - click on "Change the program" for each item, and select C:\Program Files\Internet Explorer\iexplore.exe.

    It's reversible, of course.
     
  4. tistou77

    tistou77 MDL Expert

    Mar 22, 2008
    1,285
    449
    60
    Hi

    I tried but it not work, it always launches IE x86 default

    is for the shortcut (. url) I can not use IE x64
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. blero

    blero MDL Novice

    Oct 23, 2009
    24
    3
    0
    Sorry, you're right, something was missing.

    In the same list, locate the .url extension. The current default program should be "Internet browser" (or something like that). Again, choose to change the default program and select C:\Program Files\Internet Explorer\iexplore.exe.
    It should be good.
     
  6. tistou77

    tistou77 MDL Expert

    Mar 22, 2008
    1,285
    449
    60
    I tested and it is similar, it's always IE x86 is running for shortcuts, etc...

    thanks ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. blero

    blero MDL Novice

    Oct 23, 2009
    24
    3
    0
    I have to say I read this method from some Microsoft support guy somewhere, and have to admit I didn't test it.
    I finally tested it today, and indeed it doesn't work as-is. Sorry for that.

    So I tried to see what was happening, with Process Monitor, and finally found by myself what was to be done to make IE x64 the default browser.

    - open Regedit
    - go to HKEY_CLASSES_ROOT\Applications\iexplore.exe\shell\open\command

    The data on the right has to be modified, but it's write-protected. So:
    - right click on the "command" key
    - click on "Permissions", "Advanced" button, then "Owner" tab
    - click on Administrators in the list, then Ok.
    (You just took ownership of that "command" key)

    => You're back to the "Security" tab.
    - click on "Administrators" in the top list, check "Full control" in the list below, then Ok.

    You can now modify the command on the right. Change it from:
    "C:\Program Files(x86)\Internet Explorer\iexplore.exe" %1 to "C:\Program Files\Internet Explorer\iexplore.exe" %1
    and you're done.
     
  8. ar_seven_am

    ar_seven_am MDL Senior Member

    Mar 7, 2010
    391
    124
    10
    If u use ie8 x64 as default browser, then some addons/plugins (like adobe flash player activex, quicktime etc) can't be installed becuz it just support 32 bit browser, maybe that's why microsoft use the 32 bit as a default!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. tistou77

    tistou77 MDL Expert

    Mar 22, 2008
    1,285
    449
    60
    thank you to you, I'll test it and tell you if it's good ;)

    Flash player is available for x64 ;)

    I don't use quicktime, etc ... :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. tistou77

    tistou77 MDL Expert

    Mar 22, 2008
    1,285
    449
    60
    @blero, I tested (I haven't had to change the permissions to modify the command on the right) but it doesn't work :(

    must also change the default settings in the Control Panel?

    thanks ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. tistou77

    tistou77 MDL Expert

    Mar 22, 2008
    1,285
    449
    60
    Then I modified all the registry keys "C:\Program Files (x86)\Internet Explorer\iexplore.exe" to "C:\Program Files\Internet Explorer\iexplore.exe" and is OK

    without changing the default setting in the Control Panel

    thanks ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. blero

    blero MDL Novice

    Oct 23, 2009
    24
    3
    0
    That's weird !
    I tested on a brand new installation: the key is protected.

    Yes of course, so the file type associations are correct.

    BUT I discovered something about that. If you just browse to choose the program "C:\Program Files\Internet Explorer\iexplore.exe", Windows doesn't actually change the default program, i.e. "C:\Program Files (x86)\Internet Explorer\iexplore.exe". Probably because of the same file name. I guess you could call it a bug.

    To avoid this, don't click "Browse", but choose the "other occurrence" of "Internet Explorer" in the list of programs, the one that isn't selected by default. It has to be the 64-bit one...
    Using this method, every file type association is finally correctly modified on my system.

    Of course, it makes the process a little tricky, but I can't see a better way.

    Well, this works, of course, but it's a little bit extreme ! And it makes it difficult to reverse.
     
  13. ar_seven_am

    ar_seven_am MDL Senior Member

    Mar 7, 2010
    391
    124
    10
    uuuugh u're right, I had several times before, but adobe site said they didn't support x64, I guess they change their mind ;) it's my bad, I'm sorry, anyway by now I use Ie8 x64 too as default browser (althought I use firefox, google chrome n opera too), thx for open this thread, it help a lot!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...