Intel Wifi 5100 performance problems

Discussion in 'PC Hardware' started by andacb, Feb 14, 2009.

  1. andacb

    andacb MDL Novice

    Jun 30, 2007

    I need help people. The thing is I'm going out of my mind soon, if I can't solve this problem. Here it goes:

    I've got a clean installed Samsung R560 machine with Vista SP1 64 bit with T9400 CPU, Nvidia 9600mGT display adapter, PM45 chipset and a fully 4gb of DDR3 Ram. This machine has an Intel Wifi 5100 wireless card connected in it to mini PCI express port. The machine is brand new and as I mentioned before, it is a clean install with all updates and latest stable drivers.

    The problem is like that: I can connect to wireless internet succesfully with all the speed that my ISP gives to me (in this case download 200kb/s (2Mbps)and upload 50kb/s with 2Mbit ADSL internet). The web surfing is fine, no problems at all. The torrent downloading is fine, no problem there too..

    BUT when I tried to connect to other computers within the same network (and same workgroup name) OR when any computer in my network tries to connect to my laptop using a network share or using the \\compname\d$ etc. command, the computer connects succesfully, it can browse the files BUT when it comes to watch a video from my computer or transferring any files from my computer to theirs, the network speed is so slow, that whether the video can be played nor the transfer could be made.

    I tried to ping the IP's and it gives 1ms response time, which is OK. I tried to connect via not the network name, via the IP address directly (like \\\d$ etc) but same slow speed again.

    I checked windows event log and following events are to mention related to the topic:

    Log Name: System
    Source: NETw5v64
    Event ID: 5005
    The description for Event ID 5005 from source NETw5v64 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    Intel(R) WiFi Link 5100 AGN

    Element not found

    I also tried to check the hardware using Intel Pro Wireless utility and the hardware and connection passes all the tests available. I have my firewall turned OFF and turning it On doesn't make any difference. The network connection to other computers and from other computers to my computer exists, but it is so slow that a video file cannot be played or a file transfer could not be made.

    Like a said, I have all the latest and stable versions of drivers installed and Vista Sp1 install is also clean. I've also tried previous releasse drivers for Wifi 5100 but no luck.

    The interesting point here is following: I've bought this computer a month ago and till the last week I've not experiened any problems with the network adapter. My computer was turned ON 7/24, downloading torrents at full speed and I was able to connect from any computer in my network to my computer and was able to trasnfer files, watching videos etc. One day, I got up and this happened out of nowhere..

    I don't know what else to do and waiting for your suggesstions about this issue..

    By the way, my router is not N capable, it is a discontinued model of 3Com (Officeconnect 11g with b and g support) and like I said, everything was working fine with the very same comfiguration. :)

    Thanks in advance!