Internet connection drops after idling for a while

Discussion in 'Windows 7' started by latonars, Apr 9, 2010.

  1. latonars

    latonars MDL Novice

    Nov 14, 2009
    6
    1
    0
    Hi there,

    I've been trying to fix this issue for a week but in vain.

    I running Windows 7 home premium, a wireless USB adapter, DSL modem and a router.
    Every night I go to bed leaving utorrent on and MSN messenger logging in; and every time I wake up in the morning, the Internet connection drops. I have to re-connect it despite selecting "connect automatically"o_OBut everything is alright when I'm browsing websites or so. Why it always drops when idling??:mad:

    1. setting in router is "permanent connect"
    2. Control Panel -> Power Options -> change plan settings -> change advanced power settings -> Wireless Adapter -> Power Saving mode=Max Performance
    3. Device Manager -> Wireless USB adapter -> Properties -> Power management -> Allow the computer to turn off this device to save power=unchecked

    Am I missing something?:confused:
    Forgive me if my question is too dump:D
     
  2. Ron1958

    Ron1958 MDL Junior Member

    Feb 21, 2010
    55
    1
    0
    You need to also turn off power management on the usb root hubs also.
     
  3. sam3971

    sam3971 MDL Guru

    Nov 14, 2008
    2,220
    303
    90
    What encryption do you have on your router? WPA, WPA2, WEP, or nothing? If it is on WPA2 change it to WPA, if it is on WPA change it to WEP to see if that fixes your issue. Have you tried updating your wireless adapter's driver? That could help as well. I had this same exact thing happening to me when I had a Linksys USP wireless adapter connected to a Belkin router and for some reason I had to lower the security encryption in my router to prevent the issue. That is what fixed it for me. Have you noticed it drop when you are using the computer? If not then it is probably just a power issue like Ron1958 said, try what he suggested as well dude. Good luck.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. latonars

    latonars MDL Novice

    Nov 14, 2009
    6
    1
    0
    I have WEP all along. Yes it's the latest driver already. When I'm using the computer, it definitely doesn't drop.

    "turn off power management on the usb root hubs" means usb selective suspend setting in Power Options, ??:confused:
     
  5. titian

    titian MDL Junior Member

    Sep 22, 2009
    53
    3
    0
    To turn off power saving on USB root hubs,
    go into Device Manager find Universal Serial Bus Controllers and open,scroll down to USB Root Hubs,Right click on one then select properties then power management and UNCHECK Allow the computer to turn of this device to save power.
    Do it for each hub till you get the correct one.