Internet Explorer 9 fails to install.

Discussion in 'Windows 7' started by mkuba50, Feb 17, 2013.

  1. mkuba50

    mkuba50 MDL PHP Wizard

    Nov 9, 2012
    554
    3,462
    30
    Hello! I have a problem with Internet Explorer 9. It fails to install:
    - Windows update says an error "WindowsUpdate_00003715".
    - IE9-Windows7-x64-enu.exe (full package) refuses to install, also in Safe Mode.

    All methods listed in Microsoft KB (support.microsoft.com/kb/2409098) didn't fix this problem.
    This problem is getting annoying.
    My OS is: Windows 7 Professional x64 SP1 English

    Did it happened after changing system language to Polish using Vistalizator and then reverting language to English, and removing Polish?

    What can i do to fix it?

    Sorry for my English, but it's not pretty good. ;)
     
  2. AlexAlba

    AlexAlba MDL Addicted

    Nov 27, 2012
    603
    1,094
    30
    #2 AlexAlba, Feb 17, 2013
    Last edited: Feb 17, 2013
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,574
    15,380
    340
    Never use Vistalizator; it messes up the licensing files.

    Use WAT Fix or do a repair install. Its better to upgrade to Ultimate and use any lang pack.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. mkuba50

    mkuba50 MDL PHP Wizard

    Nov 9, 2012
    554
    3,462
    30
    I have Windows 7 Ultimate Polish ISO unlocked to install every edition with eicfg_removal_utility. Can I use it to reinstall my system to Windows 7 Pro?

    My hashes of this image:
    Microsoft Windows 7 SP1 PL 64 Bit (pl_windows_7_with_sp1_x64_dvd_u.iso)
    MD5: 08045da5e522e1ddf8fe440027d8f8c7
    SHA-1: 4a5643d21853a95a3913e9fbbc7882bcb4e8deb6
     
  5. mkuba50

    mkuba50 MDL PHP Wizard

    Nov 9, 2012
    554
    3,462
    30
    I've used a WAT Fix and now I have new error code in Windows Update: "WindowsUpdate_80092004". Standalone installer refuses to install.

    Any ideas?
     
  6. mkuba50

    mkuba50 MDL PHP Wizard

    Nov 9, 2012
    554
    3,462
    30
    FixIt does nothing, it says: No problems need attention.
    So, I must reinstall my system. Can I use my unlocked to install every edition Windows 7 Ultimate Polish iso?

    Hashes:
    Microsoft Windows 7 SP1 PL 64 Bit (pl_windows_7_with_sp1_x64_dvd_u.iso)
    MD5: 08045da5e522e1ddf8fe440027d8f8c7
    SHA-1: 4a5643d21853a95a3913e9fbbc7882bcb4e8deb6

    (I don't know why I'm posting this hashes.) ;)
     
  7. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    2,357
    1,955
    90
    Sure, after all it's unlocked to install Pro, right?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. searchengine

    searchengine Guest

    @mkuba50...

    Try this...

    1. Turn Windows features on or off, untick Internet Explorer 8, and reboot.
    2. Turn Windows features on or off, tick Internet Explorer 8, and reboot.
    3. Windows Update, check for updates, accept update of IE8, and reboot.
    4. now run IE9 offline installer...
     
  9. mkuba50

    mkuba50 MDL PHP Wizard

    Nov 9, 2012
    554
    3,462
    30
    @Carlos Detweiller
    Yes, this can install Windows 7 Pro.

    @searchengine
    My Turn Windows features on or off list have only Internet Explorer 9, no Internet Explorer 8, but it exist in my system.

    @anarchist9027
    I've now installed Internet Explorer 10. Now, I'm restarting my system.
     
  10. mkuba50

    mkuba50 MDL PHP Wizard

    Nov 9, 2012
    554
    3,462
    30
    Internet Explorer 10 installed successfully and works.

    Do I need to reinstall my system anyway?
     
  11. searchengine

    searchengine Guest

    so you had IE9 installed, but were trying to upgrade to latest IE9 build, using offline installer?

    If so, then you would have needed to uninstall IE9 from 'installed updates', and reboot (Internet Explorer 8 would then have showed in 'Turn features on or off'), and then perform steps 1-4 previously advised.

    no matter now, as I see you installed IE10 Release Preview.
     
  12. anarchist9027

    anarchist9027 MDL Expert

    Oct 30, 2010
    1,320
    667
    60
    No you do not. IE 10 installed sucessfully and you are set :yeah:
     
  13. mkuba50

    mkuba50 MDL PHP Wizard

    Nov 9, 2012
    554
    3,462
    30
    Thanks for your help :). Everything now works fine.

    At the end I have a small question: Why I have only 1 Internet Explorer icon in my start menu. Is this normal in Internet Explorer 10?
     
  14. anarchist9027

    anarchist9027 MDL Expert

    Oct 30, 2010
    1,320
    667
    60
    On 64-bit Windows, the browser frame process runs 64-bit.
    However, for compatibility with plug-ins, IE 10 on the desktop runs 32-bit tabs by default.
    If the user turns on “Enhanced Protected Mode” in Internet Options, Advanced,
    he will have 64-bit tabs by default for IE 10 on the Desktop.
     
  15. kmjamal

    kmjamal MDL Novice

    Feb 18, 2013
    3
    0
    0
    I have tried everything but the problem is still there...
     
  16. mkuba50

    mkuba50 MDL PHP Wizard

    Nov 9, 2012
    554
    3,462
    30
    @searchengine
    I had an IE8 and installed IE9 but installation refused without reverting some changes, so I had IE9 in my list, but I only can use IE8.