Is it OK to be Peaved at both Microsoft and Toshiba at the same time? - UEFI Question

Discussion in 'PC Hardware' started by crazyodaz, Sep 10, 2016.

  1. crazyodaz

    crazyodaz MDL Novice

    Feb 7, 2016
    22
    6
    0
    so yea, I'll try to make this short, so I have this 2011/12 laptop cheapo black friday deal -- Toshiba L875D been trying for over 10 years to get windows 7 to install on that thing (WITHOUT CSM) mode -- originally laptop came with Windows 8 so why not -- simple downgrade should be easy -- whats 10 years of my life anyways?

    so I sorta gave up recently, been through all the BCD edits the use of this bootx64.efi file and that one, believe me i prolly have close to 200gb of failed iso attempts of non-bootable files -- its gotta be something with the stupid GOP video drivers and this is where i have to calm down and take a deep breath

    I mean who in the hell do they think they are anyways? being a AMD 4400+ there should be NO reason why it could not run GOP to make UEFI happy or whatever, but maybe its not that, maybe its both Toshiba and Microsoft, together, maybe its not really UEFI, just some sorta shim'd up pile of junk something you find at a junk yard or something?

    so recently i stumbled on a program.. Y'all might of heard of it, Paragon Disk Manager, I'm looking at this ISO and file dates are 2003 -- the file sizes are that of Windows 7 (657k 375k, ect) my eyes water, this cant be. plop it into the laptop and sure enough -- boots right up, hit F-10 and VER (i was pissed 10.0.240) VER never lies

    so my question is 2-3 maybe even 4 fold

    1) how in the heck did they get Win7 files to boot up Win10 environment? -- I ran regedit and saved the 58mb registry but thats a armfull to sift thru -- did learn some things like maybe the MSBDD is pulling off the GOP

    2) is there anybody in the computer world working on GOP for non-MS complient computers? -- its been how many years now, MS themselves even botched a few ASUS boards earlier this year because they were using Win7 and UEFI with secureboot -- MS released kb3133977, changed it to "RECOMENDED" update on purpose so it would auto install -- end story was lot of not so happy ASUS owners, they can still run UEFI, just not with secureboot on, not with kb3133977 installed.

    so we know MS aint going to do nothing, and yes true, there are some computers that UEFI iwill NEVER work on, had Windows 10 running on mine year ago, slowed this laptop right down, 8.1 same way, 7 just runs so much smoother and faster and with the new SSD and hopefully some GPT and UEFI to make it more secure (stop laughing) LOL

    it is kinda funny actually, i could run this and run that, even almost been ready to install in MBR then image it, convert the image to GPT with acronis but this thing really been getting my goat. never before have I been sto stupidly slapped in the face by a computer. I dont know everything, but gosh darn it, and with this latest find of Paragon, just re-kindling the agony of defeat

    I know there is ways to install windows from PE or RE laptop installs them fine on one hybrid version i built with the 418k file -- installs, then reboots, freezes at the start logo, classpnp.sys or something and that stupid c0x000000d error its gotta be GOP, but if it is GOP why is there not a workable solution yet -- take a look at the attachments below, pictures of proof , tell me what ya think my options are or could be, I know others are working on this, just gets frustrating sometimes, just want to know if this PARAGON loading win7 files into Win10 is legit or what --

    I added parts (not all) of the Paragon Registry from export -- dont use it, just sift through it if ya feel like it, just some things that caught my eye -- just wanna know why it works, and then how to make it work for a install

    thanx
     

    Attached Files:

  2. crazyodaz

    crazyodaz MDL Novice

    Feb 7, 2016
    22
    6
    0
    LOL -- just seeing who's paying attention , gotta lighten things up, sure does feel like 10 yrs, now days you mention Windows 7 and UEFI in the same sentence people start looking at you like some kinda voodoo child with malaria or something, like what am i, am i too good to be running Windows 10 or what? -- that type of thing, so always good to have a little fun and lighten the load -- its all good

    now when this problem gets solved i can work on getting Windows 3.1 to run on UEFI and GPT --- LOL :clap:
     
  3. Meat[On]A[Stick]

    Meat[On]A[Stick] MDL Junior Member

    Jan 1, 2015
    84
    9
    0
    No. Spreading out your peavitudiosity weakens it's effectiveness. Best to focus on one at a time.
     
  4. John Sutherland

    John Sutherland MDL Senior Member

    Oct 15, 2014
    476
    623
    10
    Hello @ crazyodaz - A very important question for you: How are you creating your Windows 7 installation media? I've found that burning the image to DVD and using that for installation just doesn't work on a UEFI machine. After booting, I would get to the first screen (language, time/currency, keyboard settings) with no problem. BUT as soon as I hit the "Next" button to proceed to the second screen, the installation process would freeze with an error message.

    What finally worked for me was using Rufus to create a bootable USB flash drive for installation. However, there are four things you must in order to make this work: a.) For 'Partition Scheme and Target System Type', select "GPT Partition Scheme for UEFI Computer"(see *** below). b.) For 'File System', select "FAT32". c.) For 'Cluster Size', select "4096 bytes (Default)". d.) For 'Create a bootable disk using', select "ISO Image", then click the disk symbol to the right and navigate to the folder where the .iso is located.

    Also, in your BIOS settings, verify these three things: a.) Secure boot is set to "Disabled". b.) UEFI boot is "Enabled". c.) Legacy/CSM boot is "Disabled". NOTE: On some systems, you'll only find one setting, Legacy/CSM. Having it set to "Disabled" implies that UEFI is "Enabled".

    ***Be sure to use a disk utility like Gparted to create a GPT partition table on the target disk. Or, you can boot the machine using your new installation media and select "Repair Your Computer" in the lower left corner of the second screen. Then navigate to the Options screen and select the Command Prompt (last option). Then use the following commands:

    list disk ### On a laptop with a single hard drive, disk 0 should be the target disk
    select disk 0
    clean
    convert gpt
    exit ### to exit diskpart
    exit ### to exit Command Prompt
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. PhaseDoubt

    PhaseDoubt MDL Expert

    Dec 24, 2011
    1,448
    278
    60
    Re: "Is it OK to be Peaved at both Microsoft and Toshiba at the same time?" I find it's quite acceptable, and common in fact, to get peeved at multiple entities simultaneously. Quite often I get peeved at the government, Microsoft, the postal service, the weather and etc. The problem is it just doesn't seem to help to spread "anger" out too thinly. Currently I'm most angry at the weather and as soon as I fix that I'm taking on the government and then all the others. I figure I've got a better chance at changing the weather so I'm taking it on first. Then the others better watch out.
     
  6. nasa

    nasa MDL Member

    Dec 2, 2007
    101
    14
    10
    I'm not sure I understand what's your end goal for an installed OS.

    Windows 7 on GPT?
    Windows 7 on GPT & SecureBoot?
    Windows 7 in general (GPT or MBR)?
     
  7. Bat.1

    Bat.1 MDL Addicted

    Oct 18, 2014
    810
    790
    30
    :g:Don't they say it's better to be peaved at instead of peaved on :confused: Unless you're a peavert and into that kinda thing :beee:
     
  8. crazyodaz

    crazyodaz MDL Novice

    Feb 7, 2016
    22
    6
    0
    #8 crazyodaz, Sep 16, 2016
    Last edited: Sep 16, 2016
    (OP)
    yea, still torn, though your rufus idea seems plausable, there is no such setting in mine,nevermind, made note, no more using my 64gb USB as rufus don't give me the 4096 option (thanx for that) -- and the laptop in question has no problem installing Win8 - 10 in UEFI mode, the problem only stems when trying to install Win7 in UEFI mode, wich really is the main reason for my brains twisted telemetry onto why this has to be so difficult of a challenge.

    again, Win7 will install on GPT disk, atleast it acts like it installs, then on first reboot it hangs at the logo, usually caused by classpnp.sys or something like that -- enclosed are some pics -- also note that I have also tried to rebuild the BCD store on several occasions, wich is why I am starting to believe, in this case, it is more than likely some silly GOP driver that Microsoft or Toshiba, or AMD refuse to build -- I have tried both DVD and USB media's again this machine only having problems with Win7x64-UEFI --- Win7 installs just fine under CSM, but that is not the objective.

    thanx again for the 4096 tip, i knew about it, but let it slip the crutches of my brain. make note to only use my 16gb or 8gb USB media and not my 64gb sticks no more -- it is sorta frustrating, can see setup trying, and putting things down to disk, but never completes setup after reboot. -- the same ISO will work fine under VMware and its UEFI mode

    **bios and uefi thumbs -- as you can see, the bios does not default to EFI in the menu, the trick to make EFI show up, is to insert 2 thumb drives, then it shows up fine, (incase others have same) also i noticed on screen / text size if actually booting into UEFI or not --- computer boots into it, just doesnt know what to do with it unless its 8 or 10

    the first one would work, not worried bout secureboot, and MBR aint a problem if i go into CSM mode, wich seems to be the answer all over the internet. theres got to be a way
     

    Attached Files:

  9. crazyodaz

    crazyodaz MDL Novice

    Feb 7, 2016
    22
    6
    0
    so.. getting closer, looks like whatever im doing is working up to a point, now we stuck again, this time i'm prolly screwed thanks to toshiba's lack of firmware updates and AMD's less than steller driver foundation, course now maybe i can image what i got, then inject drivers into the iso itself, but dont think that will help, this is all wacky -- durring MBR install non of this happens

    so what i did, manually edited the BCD Store before install, kinda sorta why i got two entree's in there, but without editing it , well it dont like to boot -- so were stuck at DISK.SYS -- crappy AMD laptop so doubt intel drivers would help, though i think XP utillizes them even when AMD board.

    crud like this should not happen, back to the drawing board -- and yes, I do know how to get Windows 7 into UEFI -- just trying to do it with dang setup.exe


    • 1.- change your bios to CSM
      2.- Install Windows 7 x64 and all your apps
      3.- make a disk image to with Acronis Truimage to other HDD
      4.- change your bios to UEFI
      5.- boot with Acronis Truimage media cd and your external HDD (where is your image)
      6.- restore your image over your internal HDD (when you restore under UEFI mode, Acronis Create the partitions under GPT schema and all your info)
      7.- when you restart the laptop you will have Windows 7 x64 over UEFI

    now with this dang disk.sys and lack of bios settings (Insyde H20) -- this might be my only option -- thanx again
     

    Attached Files:

  10. gorski

    gorski MDL Guru

    Oct 21, 2009
    2,791
    719
    90
    "...thong" m8, "thong"!!! :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...