Is it possible to install Windows Media Center on these new builds?

Discussion in 'Windows 10' started by MikeFarter, Apr 2, 2015.

Thread Status:
Not open for further replies.
  1. MikeFarter

    MikeFarter MDL Novice

    Dec 13, 2014
    19
    0
    0
    Hello,

    Has anybody tried (succeeded?) installing Windows Media Center on any of the recent builds? Is it possible?
    I tried using "Add Features", but the product key(s) that I've used before (on an old version of Windows 10 tech preview) no longer work.

    Thanks!
    mike
     
  2. ZaForD

    ZaForD MDL Expert

    Jan 26, 2008
    1,180
    177
    60
    Theres a version ProWMC in the last two Windows 10 ISO's MS has released.
    I installed the version from 10041 and WMC is exactly the same as it was in Windows 7 and 8.x
    So I don't think theres going to be any new version and maybe no version at all :(
     
  3. MikeFarter

    MikeFarter MDL Novice

    Dec 13, 2014
    19
    0
    0
    Thanks for the reply ZaForD.
    I downloaded the 10041 ISO. How does the WMC actually get installed?
    I plan on upgrading a 8.1 x64 Pro w/ Media Center workstation.
     
  4. Myrrh

    Myrrh MDL Expert

    Nov 26, 2008
    1,427
    527
    60
    Just like in 8.x

    Control Panel, Add features..., put in a valid product key for W10 WMC.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. MikeFarter

    MikeFarter MDL Novice

    Dec 13, 2014
    19
    0
    0
    Should my Windows 8 Pro w/WMC key work? When I try it, I get the error "This key won't work. Check it and try again..."
    This is the same key I used to install 8.1 onto the computer which I've upgraded to 10. It is legit (I purchased it from MS).
    Could it be that it will only work on a fresh install?

    If my key is no longer working, do I have any other options?

    Thanks for any help!
    Mike
     
  6. vista00

    vista00 MDL Novice

    Apr 26, 2014
    47
    5
    0
    Try a fresh install.
     
  7. ZaForD

    ZaForD MDL Expert

    Jan 26, 2008
    1,180
    177
    60
  8. xinso

    xinso MDL Guru

    Mar 5, 2009
    4,242
    5,511
    150
    #9 xinso, Apr 4, 2015
    Last edited: Apr 4, 2015
    ProWMC Evaluation key is not provided for Windows 10 TP

    The workaround shall be like this:

    1. Extract Windows 10 TP Pro-ISO\sources\install.wim to C:\

    2. Use explorer.exe to mount Windows 10 TP Pro-ISO, like G:

    3. Create a folder like C:\MOUNT

    4. Mount C:\install.wim index 1 to C:\MOUNT via CMD by Admin

    G:\sources\dism /Mount-Wim /WimFile:C:\install.wim /index:1 /MountDir:C:\MOUNT

    5. Upgrade the mounted image from Pro to ProWMC

    G:\sources\dism /image:C:\MOUNT /set-edition:professionalWMC

    6. Save and unmount the image

    G:\sources\dism /Unmount-Wim /MountDir:C:\MOUNT /commit

    7. Unmount Windows 10 TP Pro-ISO by ejecting G:

    8. Replace the install.wim in Pro-ISO\sources folder with this new one

    9. Delete Pro-ISO\sources\pid.txt

    10. Create/Save a file EI.CFG as follows, then add it to Pro-ISO\sources\

    [EditionID]
    ProfessionalWMC

    [Channel]
    Retail

    [VL]
    0

    11. Save the Pro-ISO as a new ISO


    Now it is good to upgrade the Windows 8.1 ProWMC by New-ISO\setup.exe or for a fresh installation.

    For activation, KMS V6 could be a solution.
     
  9. ZaForD

    ZaForD MDL Expert

    Jan 26, 2008
    1,180
    177
    60
    @Xinso,
    WOW, couldn't have said it better mate. :worthy:

    @Mike,
    I basically did what Xinso has described using the key mentioned above when asked, but IIRC theres a 'skip' or 'ask latter' link under the dialog box. Which maybe better if your going top try and activate. ;)
     
  10. MikeFarter

    MikeFarter MDL Novice

    Dec 13, 2014
    19
    0
    0
    :clap:Wow, thanks for the step-by-step. This worked perfectly with 10041. Had a problem with 10049, perhaps I messed up a step (it was late). In 10049, it prompted me for a product key when I started the upgrade, so I entered the key listed on 10049 thread. But WMC was not installed.

    When I did 10041, it installed WMC, but I had other issues like my network adapter wasn't working (appears in Device Manager, but not available the Network control panel).

    Thank you guys for all your help with this. They sure don't make it easy, do they?
     
  11. dejong12

    dejong12 MDL Member

    Jan 4, 2009
    170
    99
    10
    Can I still receive updates when I slipstream WMC into the latest 10 Pro build? Or do I need to do that process every time a new preview comes out?
     
  12. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,318
    120

    Frankly who cares about the updates since there is a new leak every 15 days?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. dejong12

    dejong12 MDL Member

    Jan 4, 2009
    170
    99
    10
    With updates I meant the new builds.
     
  14. Myrrh

    Myrrh MDL Expert

    Nov 26, 2008
    1,427
    527
    60
    Again, since we have ways to download manually the ESD, and turn it into ISO, who cares?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,318
    120

    For the record the ehome (WMC) related MUIs are included in the LPs but, curiously enough, they are in the English version, so you can get the Mediacenter translated from English to English :D

    I solved quickly taking the ones from build 10036, and overwriting the wrong ones.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. dejong12

    dejong12 MDL Member

    Jan 4, 2009
    170
    99
    10
    Can you tell me how you took the other language's files for WMC?
     
  17. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,318
    120
    #18 T-S, Apr 7, 2015
    Last edited: Apr 7, 2015

    Well I had the LP.cab in my language, I unpacked it with 7zip, then I looked for the filenames in

    \windows\ehome\en-US to understand the MUIs i needed, then I searched for them them inside the unpacked LP and I copied the files, one by one, in \windows\ehome\yl-YL(where yl-YL= your language).

    (I suggest to use agent ransack instead of the useless windows search to find the files inside a such folder made by a zillion of files)

    Alternatively you can grab an iso already in your language, open install.wim with 7zip and extract the whole yl-YL folder.

    Obviously you can also take it from a working installation.

    I used 10036, I don't know if 10041 is affected or not, likely something older works too. But a way too old release will not work because the kernel numbering change, even if WMC is practically unchanged since win 7
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  18. Kuantum Freak

    Kuantum Freak MDL Junior Member

    Mar 30, 2015
    99
    16
    0
    I'm confused, I did a clean install of 9926 last week, and then I updated to 10049 (I needed to dual boot Win 8.1), and I have Windows Media Player up and running. Windows media player MDL.jpg :confused::confused:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. ZaForD

    ZaForD MDL Expert

    Jan 26, 2008
    1,180
    177
    60
    The topic is Windows Media Centre not Windows Media Player. ;)