Lenovo B490 (20205) BIOS corrupted. No more display. Help! (Insyde H20 Bios)

Discussion in 'BIOS Mods' started by kamesh_ss, Sep 4, 2016.

  1. kamesh_ss

    kamesh_ss MDL Novice

    Sep 4, 2016
    1
    0
    0
    Hello guys!
    This is Kamesh. And I own a Lenovo B490 (20205) laptop that was provided by Govt. of TN. I had the B460 before. I tried to update the correct BIOS on B460 that was downloaded from Lenovo IN site. And it worked perfectly without any problem. The Govt. of TN logo disappeared and the normal Lenovo Logo appeared on B460. So this is fine.

    Now that I have the B490 and I tried the same. I downloaded the BIOS update from Lenovo IN site by inputting my Laptop serial number and it showed my laptop as Lenovo B490 which is correct. So, I saw that the BIOS update was available. I decided to download and install it. I had Windows 10 64 bit in my Laptop. I installed it and I started the BIOS update it showed me the usual warnings such as Connect AC adapter. I did all the things (I've previous experience of updating the BIOSes). So, it started to flashing the BIOS and after some time the laptop didn't turn on. Found out that the BIOS didn't post. The screen was complete black.Now that my Laptop won't post.

    I tried many methods on internet to recover the BIOSes. I tried the WinCrisis.exe method and found out that it works only with Phoenix BIOS. And I have Insyde BIOS.

    Please let me know if you can help me with this.

    I've been trying so much. Couldn't find any solution.

    Please help me!

    PS: I got the working BIOS from my friend's laptop as it's the same Laptop and Same model number.

    Its an Insyde H20 BIOS. Please tell me how to recover it.
     
  2. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,418
    1,483
    180