LTSB N 64bit lost NTLDR NTDetect problem

Discussion in 'Windows 10' started by StevenM, Oct 12, 2015.

  1. StevenM

    StevenM MDL Novice

    Oct 13, 2012
    7
    0
    0
    I have two Windows partitions; my old W7 partition that I use for upgrade testing etc, and my active W10 LTSB partition. Now I want to remove the old W7 partition and use the space for LTSB. But it holds the boot info and files. When I set it inactive and the LTSB one Active I get the Boot error; NTLDR missing. How can I get my LTSB partition booting correctly - whilst maintaining all programs and files?
     
  2. endbase

    endbase MDL Guru

    Aug 12, 2012
    3,901
    1,196
    120
    #2 endbase, Oct 12, 2015
    Last edited: Oct 12, 2015
    You proberly would have to set the LTSB as primairy OS with BCD edit After that reboot check if it's correct and clean the w7 partition and then save the BCD settings again for safety ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. lt

    lt MDL Novice

    Nov 29, 2012
    47
    38
    0
    #3 lt, Oct 12, 2015
    Last edited by a moderator: Apr 20, 2017
    after switching active partition, you have to create/update your bcd file. easiest way is to boot from winpe, run this command from cmd prompt:

    Code:
    bcdboot x:\windows /s x:       (both x: are your win10 partition drive letter)
    win 7 and win10 dont use ntldr, you got it from old winxp install perhaps?
     
  4. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,318
    120
    #4 T-S, Oct 12, 2015
    Last edited: Oct 12, 2015
    The previous messge is the correct answer.

    The boot code must be the one from w10 to dualboot properly
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. StevenM

    StevenM MDL Novice

    Oct 13, 2012
    7
    0
    0
    Ok. Got it - Thanks.