Malwarebytes slow to start.

Discussion in 'Application Software' started by jetjock, May 25, 2011.

  1. jetjock

    jetjock MDL Senior Member

    Mar 6, 2010
    279
    15
    10
    I have Malwarebytes v.1.50.1.1100 installed and set to start with Windows. The program seems to working just fine, but it takes two minutes to load after Windows is done loading. I have it on three computers that have varying amounts of programs and memory installed but it takes the same time to load on all three. Two computers have Windows 7 Ultimate and the third has Home Premium. Is there any way to speed up the start time of Malwarebytes?
     
  2. Josh Cell

    Josh Cell MDL Developer

    Jan 8, 2011
    3,519
    7,096
    120
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Deeb

    Deeb MDL Novice

    May 12, 2011
    1
    0
    0
    I believe the default setting for the MBAM Service is Automatic(Delayed Start), which would explain the delay you are seeing.
    If it bothers you, you can change the service to Automatic, instead of the default Automatic(Delayed Start)
     
  4. R29k

    R29k MDL GLaDOS

    Feb 13, 2011
    4,650
    4,227
    150
    You can try this
    Go into your Prefetch (C:\Windows\Prefetch) folder and delete everything in it.
    Then open a command prompt with admin access and run this rundll32.exe advapi32.dll,ProcessIdleTasks
    Then when that's done, will take a while, run this defrag %homedrive% -b, wait till it's done of course. :D Then reboot, you might require 1 more reboot to see benefits.
     
  5. jetjock

    jetjock MDL Senior Member

    Mar 6, 2010
    279
    15
    10
    Thanks to all who answered my question. The above appears to be the answer I was looking for. I had no idea there even was such a thing as "delayed start". I have changed to "Automatic". Here is what MalwareBytes had to say about it:


    I have Malwarebytes v.1.50.1.1100 installed and set to start with Windows. The program seems to working just fine, but it takes two minutes to load after Windows is done loading. I have it on three computers that have varying amounts of programs and memory installed but it takes the same time to load on all three. Two computers have Windows 7 Ultimate and the third has Home Premium. Is there any way to speed up the start time of Malwarebytes?

    Mike.

    Tom Mercado, May-25 15:25 (PDT):

    Hello and welcome to the Malwarebytes consumer helpdesk. Thank you for choosing Malwarebytes' Anti-Malware as your malware security solution, my name is Tom Mercado and I'll be assisting you today.

    This is done by design to avoid conflicts with other security software, there is no concern for lack of coverage.
     
  6. BibuConn

    BibuConn MDL Novice

    Nov 19, 2009
    24
    0
    0



    I'm not seeing where to go to change that setting though. How did you do it, step by step please?
     
  7. jetjock

    jetjock MDL Senior Member

    Mar 6, 2010
    279
    15
    10
    Click "Start", "Run", type in "services.msc" and click "OK". Scroll down to "MBAMService", double click on it and then change startup type to "Automatic". Click "OK" and close open windows. Be advised that this worked fine on one computer, but gave an error message on another when it rebooted. I haven't had time to re-change it on that machine to see if it just a glitch or really won't work. Good luck.
     
  8. BibuConn

    BibuConn MDL Novice

    Nov 19, 2009
    24
    0
    0
    Thank you very much.

    I'll give it a shot and report back.
     
  9. BibuConn

    BibuConn MDL Novice

    Nov 19, 2009
    24
    0
    0
    By the way, it worked!

    Thanks again.