MEMORY ISSUE: installed 6GB, only 3GB avaialble

Discussion in 'Windows 7' started by ryaxin, Sep 9, 2009.

  1. ryaxin

    ryaxin MDL Novice

    Sep 3, 2009
    29
    0
    0
    Performance monitor shows that at least 3GB of memory is reserved for programs, just over 1GB is free and just under 1GB is on standby while the rest is being used throughout normal operation.

    I've tried to fix this issue within the msconfig option and on some modifications (within Boot-Advanced options-memory) it won't even boot at times.

    I looked into my BIOS to see if there is an option to free up memory or unlock memory and nothing is avaialble. (unless I am missing something :rolleyes:)

    My BIOS is from AWARD Phoenix.
    I had no issues with Vista Home Premium x64, all 6GB were available.

    Here are my system specs:

    MODEL:ACER ASPIRE M5100

    CPU:AMD ATHLON 64 X2 6000+ Windsor 3.0GHz Socket AM2 125W Dual-Core Processor

    MOTHERBOARD:F690GVM

    COOLING:ARCTIC COOLING Freezer 64 Pro 92mm CPU Cooler

    VIDEO CARD:BFG NVIDIA GeForce 8800 GT OC GDDR3 512MB PCIe 2.0 - 256bit **NVIDIA driver version 185.85**

    MEMORY:KINGSTON 4GB (2 x 2GB) 240-Pin DDR2 SDRAM 800 (PC2 6400) Dual Channel Kit
    NANYA 2GB (2 x 1GB) 240-Pin DDR2 SDRAM 667 (PC2 5300) Single modules

    HARD DRIVE:WESTERN DIGITAL Caviar Black 500GB 7200 RPM 32MB Cache SATA 3.0Gb/s 3.5" Internal Hard Drive

    POWER SUPPLY: DYNEX (DX-PS500W) 500W ATX PC Power Supply

    OS:WINDOWS 7 Ultimate OEM – 64bit
     
  2. BubuXP

    BubuXP MDL Member

    Jul 21, 2009
    144
    31
    10
    Have you switched on the Memory Remap feature in the BIOS?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ryaxin

    ryaxin MDL Novice

    Sep 3, 2009
    29
    0
    0
    #3 ryaxin, Sep 9, 2009
    Last edited: Sep 9, 2009
    (OP)
    I do not have that option in my BIOS.

    Unless it is under a completely different name....

    I have an option called 'Memory Hole' but not certain what that does....
     
  4. BubuXP

    BubuXP MDL Member

    Jul 21, 2009
    144
    31
    10
    Does Win7 recognize all 6 GB in System properties?
    Or your problem is how Windows manages the memory?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. ryaxin

    ryaxin MDL Novice

    Sep 3, 2009
    29
    0
    0
    Yes, all 6GB are recognized in system properties.

    Good point for your second question, I guess I should be questioning the following:

    Is there an issue with how the memory is being managed in Windows 7?
     
  6. BubuXP

    BubuXP MDL Member

    Jul 21, 2009
    144
    31
    10
    No issues. It's the way Windows 7 works (I suppose).
    I installed 7 on a laptop with 448 MB of ram. The manager says all the ram was in use but Windows7 worked smoother than XP.
    I think Win7 use the ram as cache, don't worry.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. jjkkll

    jjkkll MDL Novice

    Aug 29, 2009
    20
    0
    0

    How do you want it to manage the RAM?

    What was vista doing?
     
  8. ryaxin

    ryaxin MDL Novice

    Sep 3, 2009
    29
    0
    0
    #8 ryaxin, Sep 9, 2009
    Last edited: Sep 9, 2009
    (OP)
    Well I guess when I look into system properties and see 6Gb installed (3GB available) I question if all memory is in fact being used. Perhaps the wording within system properties is misleading then, not only to myself but to many other users.

    But the same applies when I only install 4GB, system properties shows 4GB installed (only 3GB available).... it's as though no matter how much memory I install it will recognise it all, but it seems to constantly tell me that only 3GB is available. Does it mean 3GB is reserved or only 3GB is used out of the 6GB installed (meaning the other 3 are wasted)?
     
  9. jjkkll

    jjkkll MDL Novice

    Aug 29, 2009
    20
    0
    0
    #10 jjkkll, Sep 9, 2009
    Last edited: Sep 9, 2009
    Is it definitely the 64bit OS?

    are the chipset drivers up to date?

    Is it Dynamically allocating that other 3Gb to VRAM?
     
  10. jjkkll

    jjkkll MDL Novice

    Aug 29, 2009
    20
    0
    0
    #11 jjkkll, Sep 9, 2009
    Last edited: Sep 9, 2009
    If that is what is happening then the fix would be, remove the GFX card driver and allow 7 to install its own one from windows update.

    i.e remove "**NVIDIA driver version 185.85**" and allow windoes to replace it with the WDDM 1.1 driver set from win update.
     
  11. AzN1337c0d3r

    AzN1337c0d3r MDL Novice

    Sep 3, 2009
    8
    0
    0
    Take a screenshot of your systems properties please.

    It sounds like you installed 32 bit Windows 7.
     
  12. OleBent

    OleBent MDL Member

    Aug 22, 2007
    122
    1
    10
    Certainly sounds like that.
     
  13. jjkkll

    jjkkll MDL Novice

    Aug 29, 2009
    20
    0
    0
    The guy says in the OP that he has 64bit installed, if he knows that then ts unlikly to be an error, in OS installation.

    Also it is know than OEM gfx drivers can casue these errors, on 64bit OS's.
     
  14. whitehat2009

    whitehat2009 MDL Member

    Aug 1, 2009
    163
    2
    10
    Enable the memory hole option in the BIOS - basically, the computer treats the upper RAM limit as PCI addressing space. With memory hole remapping on, the PCI addresses will be reallocated to >4GB, making the RAM available for system use.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. Johnessen

    Johnessen MDL Novice

    Aug 25, 2007
    38
    6
    0
    If you are sure that you are running 64bit of windows 7, you can try this from within windows.Start, Run, Msconfig, , Boot, Advanced Optios.Check Maximum Memory and increase the value to your 6gb value.Don´t forget the OK buttons.Goodluck
     
  16. jjkkll

    jjkkll MDL Novice

    Aug 29, 2009
    20
    0
    0
    and this!!!!!!
     
  17. ryaxin

    ryaxin MDL Novice

    Sep 3, 2009
    29
    0
    0
    It is definately 64bit.

    This issue is one that has plagued many 64bit Win 7 Ultimate users.

    I suspect it just may very well be the BFG driver. I will wipe out version 185.85 and install the version with the WDDM 1.1 driver set. I could always get this from the Nvidia website.

    I'll give it a try and report back on the end result.