Metro Apps crash/do not work properly when using modded amd 12.10 drivers

Discussion in 'Windows 8' started by level143, Nov 8, 2012.

  1. level143

    level143 MDL Novice

    Oct 14, 2012
    13
    4
    0
    Hey guys, I am using Windows 8 Enterprise x64 RTM on an Intel Core 2 Duo Acer laptop with 4GB RAM and ATi Mobility Radeon HD 4570 graphics. Too bad AMD left us "legacy" guys in the lurch even though the hardware is pretty capable as such only Microsoft signed drivers (WDDM 1.1) seem to work, even though the hardware is fully supports WDDM 1.2. I finally got to install the AMD 12.10 drivers which enabled better OpenGL support and enhanced performance in all programs that use GPU Acceleration. But they run only in the "TEST" mode. I tried to manually sign the files using DSEO but still not much use. I was ready to put up with it, but strangely, some of the metro apps like Music, Video and any other app that streams or plays multimedia suddenly started crashing. Even Windows Media Player using ffdshow started to crash while playing MKVs (.avi and .mp4 work fine though). I am able to play local media in these apps. Only streaming content is crashing the app. The problem disappears as soon as I revert back to the old driver though. Seems like strict rules are in place in the x64 version regarding Metro apps verifying that all drivers are signed. I read somewhere that x32 versions run without any problems.

    Any clue as to how to prevent the crashing of Metro apps under these new modded drivers and any ideas to avoid TEST mode and still continue using the modded drivers??? Meanwhile, I happened to look at the event log from which I learnt that the WWAHost.exe which hosts the modern UI JScript seems to have a problem with unsigned drivers that are not WHQL certified. Even the 12.6 legacy drivers, although they install without a problem, seem to have a problem with the Modern UI apps as these drivers are self signed by AMD (may be coz they thought why pay MS $500 to get
    legacy drivers WHQL certified...what a crap way to deal with customers!!). As of now, only WHQL certified drivers work. Using the Microsoft certified driver for the moment. I am looking at a way to prevent Modern UI apps (esp. the WWAHost.exe) service to ignore the signature or something on those lines. Hope someone out there figures it out.


    Thanks ! :)