Metro apps issues (audio; video; camera...)

Discussion in 'Windows 8' started by guillaumeiii, Aug 19, 2012.

  1. guillaumeiii

    guillaumeiii MDL Novice

    Aug 17, 2012
    12
    0
    0
    Hi !

    I recently installed Windows 8 RTM Enterprise X86 on my PC, and I am having issues with some Metro apps.

    The music player keeps crashing (immediatly) when I try to play a song. Moreover, all (metro) applications that may play music (web radios such as TubaFM i.e) do not work too.
    The video player won't play any video (keeps loading the file, not playing it) and so do other apps that play online videos, such as France24 news app (and all other video apps...).
    Finally, when trying to launch the Camera app, it says me "Sorry. The camera app cannot be used with this version of Windows". I tried another App Store app that used the webcam ; pretty much same result, it crashes.

    The weird thing is that video and audio playback work perfectly in Google Chrome (desktop), Windows Media player (on desktop too) etc... I guess I am missing some sort of protocol allowing me to have audio and video playback in the Metro interface...Same for the use of webcam.

    Does anyone have that problem too?
    What can I do to fix it ?

    Thanks in advance,

    Guillaume

    PS : excuse my English, as I am French native.
     
  2. guillaumeiii

    guillaumeiii MDL Novice

    Aug 17, 2012
    12
    0
    0
    I just reinstalled Windows 8 X86 Enterprise, and nothing changed. Media playback in the Metro interface won't work.

    Does someone has a hint to try to make it work ?
     
  3. SiXXGuNNZ

    SiXXGuNNZ MDL Novice

    Aug 12, 2012
    8
    9
    0
    install codecs. ffdshow(both audio and video or just video) up to you. ac3filter works for audio also.
     
  4. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    7,008
    7,165
    240
    install the original drivers for both video and audio available on the manufacturers website.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. guillaumeiii

    guillaumeiii MDL Novice

    Aug 17, 2012
    12
    0
    0
    #5 guillaumeiii, Aug 19, 2012
    Last edited: Aug 19, 2012
    (OP)
    I installed ffdshow and ac3filter with the recommended settings, and it did not fix the problem. I am not sure it is related to general media playing codecs, since music playing works perfectly with the Zune Desktop Player, or Windows Media Player. Same, video playback works with Windows Media Player or VLC.

    The problem only occurs when trying to use the Metro Apps, such as Music, Video, TubaFM, Web Radio, France24 (etc) that have to manage some sort of media playback.

    I'll try that, but I'm not sure it will change something, considering audio and video work in "normal" Windows. It's just the Metro apps that don't seem to manage it.
     
  6. buksnatata

    buksnatata MDL Member

    Oct 22, 2011
    212
    92
    10
    Everything here works ok
     
  7. RCOO

    RCOO MDL Senior Member

    Jan 15, 2009
    480
    8
    10
    Are you messing with the watermarks? I had the same problem, because I removed my watermark. When I restored the watermark they started working properly again.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. dailyinsanity

    dailyinsanity MDL Junior Member

    Aug 17, 2012
    71
    6
    0
    If you activate Windows 8, the watermark disappears. Now Video Playback is only included in the Pro Windows Media Center edition. They removed the playback from Windows Media Player to make you buy the Media Center.
     
  9. guillaumeiii

    guillaumeiii MDL Novice

    Aug 17, 2012
    12
    0
    0
    Nope, not messing with watermarks. My Win8 RTM version is activated ! No watermarks anymore.

    Sure, but on my second PC on which I installed Windows 8 Pro WITHOUT the Media Center Pack, everything works fine. Are you saying it is not possible to use Video Playback on Win Enterprise ? Weird because Video playback in Media Player works in Enterprise...the problem is Metro, not Media Player.

    I'll install that. Keeping you informed.
     
  10. guillaumeiii

    guillaumeiii MDL Novice

    Aug 17, 2012
    12
    0
    0
    install.cmd doesn't seem to work, saying me that the files were not found (in the terminal). Otherwize, installing updates appropriate to my version didn't change anything...

    Too bad o_O

    Do Metro apps use special codecs or not ?
     
  11. McRip

    McRip MDL Addicted

    Aug 15, 2011
    935
    3,416
    30
    That's about your permissions.
     
  12. Hentrax

    Hentrax MDL Novice

    Aug 14, 2012
    4
    0
    0
    I have the same problem and updates from win8.cesidian.info didn't solve it.

    Is there anything else we can do?
    What is the problem with the permissions?
     
  13. guillaumeiii

    guillaumeiii MDL Novice

    Aug 17, 2012
    12
    0
    0
    Thanks so far! As said Hentrax (not alone \o/) though, which permissions are we suppose to change in order to make it work ?
     
  14. vcfan

    vcfan MDL Novice

    Aug 11, 2012
    6
    2
    0
    windows 8 enterprise DOES NOT HAVE MEDIAFOUNDATION, so no media apps will work. that is why some apps crash and others wont play media,because mf is missing. also,some pc games rely on mediafoundation,and if you don't have it, they wont run,like saints row 3.
     
  15. guillaumeiii

    guillaumeiii MDL Novice

    Aug 17, 2012
    12
    0
    0
    Oh, I see...But then, why does Windows Media Player or Zune Desktop work ? And my son played an old game (Zoo Tycoon) and sound worked...

    Anyway, you should be right. But then might it be possible to install MediaFoundation so that media apps shall work?
     
  16. Hentrax

    Hentrax MDL Novice

    Aug 14, 2012
    4
    0
    0
    #17 Hentrax, Aug 21, 2012
    Last edited: Aug 21, 2012
    hem.. I have Windows 8 pro... (Installed with the MSDN image, and not activated.)
     
  17. vcfan

    vcfan MDL Novice

    Aug 11, 2012
    6
    2
    0
    windows media player still supports directshow,so theres no reason it shouldn't work. only mediafoundation codecs wont work. I think wmv is mf, not sure if theres a directshow one too. and not many games use mediafoundation,but some do. if zoo tycoon works fine,then its not dependant on mf.
     
  18. guillaumeiii

    guillaumeiii MDL Novice

    Aug 17, 2012
    12
    0
    0
    So is there no way to install "manually" these codecs ?
     
  19. pandev92

    pandev92 MDL Novice

    Aug 24, 2012
    3
    0
    0
    I have exactly the same problema with Windows 8 Enterprise N, the music and video App doesn't work, YouTube App too .. :(