mobo is dead?

Discussion in 'Windows Vista' started by Linux4ever, Feb 11, 2008.

  1. Linux4ever

    Linux4ever MDL Novice

    Jan 25, 2008
    28
    3
    0
    #1 Linux4ever, Feb 11, 2008
    Last edited: Feb 11, 2008
    I have a K9A2 Platinum board. I tried the method one for AMI bios. I got two green from the program but after I flash my bios and restarted my machine the board became dead. The monitor is shows nothing but I can hear my processor fan going. The lights on my ram flashes. I don't hear any beeps. I notice I have JSPI1 port where I can flash the bois that way. Is there any equipment I can get to flash it through JSPI1 that way i don't have to RMA. Or is it better to call MSI and RMA the mobo.

    Mobo: MSI K9A2 Platinum V1.0
    CPU: Athlon 5000+ Blackbox edition
    RAM: Crucial 2x1GB of PC2 8500 in dual channel x2 = 4GB total
    Video card: Radeon HD3870 x2 in crossfire
    UPS: Silencer 750
    BIOS: F71882FG chip using AMI...

    I have tried clearing the CMOS it doesn't work. I have try with a PCI video card that didn't work. I have try with just 2GB by itself that didn't work. So my conclusion is that the mobo cmos is dead.
     
  2. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,375
    11,258
    340
    #2 Yen, Feb 11, 2008
    Last edited by a moderator: May 23, 2017
    Hi,

    what about this:

    http://forums.mydigitallife.net/posts/13395

    BTW: The CMOS never dies. It's the bioscode itself, which is on the EEPROM that isn't working anymore. A replacement of the chip, or reprograming of it would resolve the issue.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Linux4ever

    Linux4ever MDL Novice

    Jan 25, 2008
    28
    3
    0
    i tried that method, it won't even read the floppy drive...
     
  4. the-paperboy

    the-paperboy MDL Junior Member

    Jun 1, 2007
    50
    0
    0
    From MSI site:

    BIOS Recovery Feature

    For AMI BIOS
    1. Rename the desired AMI BIOS file to AMIBOOT.ROM and save it on a floppy disk. e.g. Rename A569MS23.ROM to AMIBOOT.ROM
    2. Insert this floppy disk in the floppy drive. Turn On the system and press and hold Ctrl-Home to force update. It will read the AMIBOOT.ROM file and recover the BIOS from the A drive.
    3. When 4 beeps are heard you may remove the floppy disk and restart the computer.


    In my experence, you must have the floppy in the disk drive and be holding down the Ctrl and Home keys BEFORE, and hold them down while powering on the PC. Keep the keys held down until the PC starts reading from the floppy. Be sure the *.ROM file is named AMIBOOT.ROM.
     
  5. Linux4ever

    Linux4ever MDL Novice

    Jan 25, 2008
    28
    3
    0
    I tried that using the floppy... But when i press ctrl-home it won't even access the floppy. Anyway I RMA it back to MSI and sent it to them today...
     
  6. kmcguire

    kmcguire MDL Novice

    Feb 2, 2009
    1
    0
    0
    #6 kmcguire, Feb 2, 2009
    Last edited: Feb 2, 2009
    Flashing MSI Board JSPI1 Header

    Yes, the BIOS serial flash chip can be flashed through the JSPI1 header.

    I happened to flash the wrong bios which disabled the board. It gave three beeps which indicate a memory error however this was because of the BIOS that was flashed not being compatible with my board. The memory was fine.

    Also no video or anything.

    My board had a Winbond W25X80AVSIG serial flash chip. My board was a DKA790GX. I use a FTDI chip in MPSSE mode to interface with the board through the JSPI1 header. I have seen people use a parallel port and do it too!

    There exist four primary pins. A MISO, MOSI, CLK, and CS. On the Winbond you had to pull the CS low to active the chip and shift in data on the MOSI and then get data shifted out on MISO. You have to be careful. Some Winbond commands are shifted in on a different CLK edge and the same with the data. Also CS has to be brought low and high correctly. Also the board has to be powered down. No power supply connected. I used the 3.3V from my power supply to power the chip which indirectly powers some of the board like the power LED, but everything worked fine.

    The protocol used is SPI. MSI is using a industry standard method. Nothing special or cryptic.

    Once you get communication correctly with the chip. You can simply erase the entire chip and upload the new BIOS from a file in 256 byte chunks. Then download and verify with a binary hex comparison.

    I rebooted and the board worked excellent! Took four days.

    Also to note. Most people end up having the flasher automatically set the write boot block switch. This is bad! Do not do this unless you call support first and verify this is the correct thing to do. Never flash the boot block unless it is the recommened method. I ended up flashing the boot block which gave me all these problems, which I fixed. But, it took a lot of time and expertise. If you do not flash the boot block then the AMI bios recovery procedure will work. It _should_ work from a USB stick too! So _never_ _ever_ _never_ flash the boot block. It is the only **easy** way to get the BIOS restored.