Modding my Abit NF7 v2....What settings for the Award Tool ???

Discussion in 'BIOS Mods' started by tnx, Oct 29, 2010.

  1. tnx

    tnx MDL Expert

    Sep 2, 2008
    1,622
    233
    60
    Hi all.

    I have a question or two about modding an old AMD board,Abit NF7 v2.

    I have managed to mod a couple of boards myself,some have worked fine and some have bricked out.This time i want to make sure i do it right so what i would like to know is,

    I have downloaded the Award BIOS mod tool and when i select the BIOS.BIN file there is one thing which slightly confuses me and i think this is where i am going wrong and bricking some boards.It's the settings where you can select "ISA - PUBKEY - SSV3" etc etc.
    It seems the default is "0+2" but i have read on the forums regarding BIOS modding some folks use SSV3.

    How do i know which one to pick,is there some rule of thumb for different boards ?If there is what is it ?

    Another thing is i guess if i just want to put SLP1 so i can activate Windows XP only do i just select the "SLP" file and leave the "SLIC" file empty ?

    I have infact downloaded from here a BIOS file for the board already modded to SLIC2.1 with HP info on it. I would try this but i think i get more satisfaction knowing i did it myself.

    Hope somebody can give me some tips here.

    Cheers..
     
  2. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,171
    10,928
    340
    Andy's tool allows to choose the bios manufacturer and then it chooses the right settings for the best method.

    The right settings were determined by several tests before.
    You may choose a SLP file only if you don't want to add a SLIC.
    0+2 is one of the safest mod method for Award.
    I have developed it for sensitive Award bioses...;)
    SSv3 puts the SLIC into the main module and is a safe method as well.
    ISA is safe as well, but doesn't activate at Abit Award bioses (SLP2.x)

    Anyway when adding SLP1.0 only it doesn't matter, since the mod method refers to SLP2.x (inserting a SLIC).
    The SLP1.0 string is inserted into the mainmodule always...there is one method only..
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. tnx

    tnx MDL Expert

    Sep 2, 2008
    1,622
    233
    60
    Thanks Yen....

    Hopefully the board will come tomorrow so i can get on with the job. Just wanted to make a nice little cheap system so i chose an old AMD to match an old chip and RAM i already had in my box of tricks.

    I will just stick with the 0+2 setting i think.
    I did not know when you selected the mobo type the tool selected the correct settings for that board. That was a good touch and good to know in the future.

    Thanks agaain..
     
  4. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,171
    10,928
    340
    I still have an Asus A7N8X deluxe board at my own built PC as my second one. (Athlon 3200+) It still runs fine and has a Award bios as well..
    Good luck.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. tnx

    tnx MDL Expert

    Sep 2, 2008
    1,622
    233
    60
    Will update with my result..

    Fingers crossed..
     
  6. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    491
    180
    I have this exact board with OEM7 mod..works perfect..I have used ISA also..this should not brick.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. tnx

    tnx MDL Expert

    Sep 2, 2008
    1,622
    233
    60
    OEM7 ?

    Is that SLIC2.1 info ?

    I suppose thinking about it,really i should add SLIC2.1 + SLP info in one BIOS flash then i dont have to do it again. Cant see this machine being any good to run a new OS to be honest.
    Probebly just stick to XP.
    For a laugh though i might go back in time a take a look at Windows 95 + 97 and even ME. Just for old time sake.Well it will only have 256mb RAM.Wont even need to flash the BIOS to install those.
     
  8. tnx

    tnx MDL Expert

    Sep 2, 2008
    1,622
    233
    60
    #8 tnx, Oct 30, 2010
    Last edited: Oct 30, 2010
    (OP)
    Well as usual i fall at the first hurdle.

    I won the new Abit board and was gunna sling it in my old case,quite,no very old case. Had a look at the PSU and there is no ATX 12v connector,just the long power connector. Damn.Gunna have to buy a new ATX PSU. Bugger.
    Thought i had it worked out.


    heyyyyyyyyyyyyyyyy..

    Had a route round in the loft and found an old 350w PSU with the ATX12v connector. Back on track..
     
  9. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    491
    180
    SLP 1.0 is non-issue, the SLIC info should be done with OEM7 or 0+2 (I have had success with ISA but not consistent)..either way, you should add info to DMI if you do this..maybe with dmicfg or boot disk. I have used DMICFG with all success with right strings..Which OEM do you want for SLP 1.0.

    The machine I have has run Vista and W7 very well. 3 gb ram and Athlon 2800+ Barton core. XP is a dream on this machine...Very strong setup IMO..
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. tnx

    tnx MDL Expert

    Sep 2, 2008
    1,622
    233
    60
    Good info there mate.

    The OEM i will go for will be "Dell"...Dont know why i keep choosing Dell but all my other machines have Dell info,might as well stick with the same.

    The chip is an AMD 2200 with only 256 RAM ( not sure if its DDR400 or what though )..

    DMI and DMICFG....????????? Sorry mate but i am not sure what you mean there.

    I do have all the files to make myself a Windows XP SP3 Pro OEM disc. Vista and W7 as well. Making the discs is the easy bit,flashing the BIOS always gives mi the jittters.The odd one or two brick out.

    Got my eye on another Asrock mobo, Intell 775. I have done one of these already and is still working very well on W7. I have a spare P4 sat doing nowt.Just depends on the price.Some of them go for silly money,the price of brand new boards.

    Any way i digress...
     
  11. tnx

    tnx MDL Expert

    Sep 2, 2008
    1,622
    233
    60
    One more question.

    I have a brand new Compaq lappy. I just used the SLIC Tool Kit 3.2 to back up it's Cert,key and a "BIN" file. ( If i think right this is the SLIC 2.1 info ) Is this right ?

    i was wondering could i infact use these files in the Award BIOS Tool to update the Abit NF7's BIOS ready for flashing.
    My new machine would then become a Compaq.
    Or would this be bad idea ?
     
  12. tnx

    tnx MDL Expert

    Sep 2, 2008
    1,622
    233
    60
    Well using the Award tool i keep getting the error

    "can noy write main module"

    This is using the Dell info which comes along with the Award Tool. On setting 2+0.

    Will try using ISA and see what happens.
     
  13. tnx

    tnx MDL Expert

    Sep 2, 2008
    1,622
    233
    60
    Well i used the tool once more on ISA settings .
    Used the Cert,SLIC2.1 info i dumped from the new Compaq lappy.
    It said it worked a treat. Sounds good to me !
     
  14. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    491
    180
    If no activation, PM me..
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. tnx

    tnx MDL Expert

    Sep 2, 2008
    1,622
    233
    60
    Will do mate. Intrigued now. I guess you have files...

    Just got to wait for the board to come.
    Sometimes ebay can be a right pain. No word or owt from the seller. Will give it a few days.
     
  16. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    491
    180
    I have files, but more to the point experience with this board..Abit can be a PITA to activate with SLIC.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. tnx

    tnx MDL Expert

    Sep 2, 2008
    1,622
    233
    60
    Well the board came and works a treat.
    I installed XP and all worked well and after checking for OEM info and finding none i decided to flash the BIOS.

    I updated my BIOS using 911medic's NF7D_27.BIn file.

    Thanks for that mate.

    The PC went through the flashing program OK. I switched off and cleared CMOS and phew it boots again. I can go through the BIOS screens so i know flashing was succesfull but i have a problem...

    XP did not boot up.
    So i decided to install a fresh copy,using the same install disc as i used to install XP just before i flashed. It has no OEM info files on it. Just a basic XP SP3 Pro disc.
    I got an error i have never seen before

    ERROR.
    File i386\KDCOM.dll not found
    error code 7.

    Looking at this i think this is related to not using a modded XP install disc cause the i386 folder on the disc is where the modded files are located,are they not ?

    Not got time just at the mo to make myself a XP disc with HP OEm info,but i will do.

    Just wondering has anybody seen this error ?