Need help debricking Asus F8Sp laptop

Discussion in 'BIOS Mods' started by BarnacleBarge, Jul 19, 2016.

  1. BarnacleBarge

    BarnacleBarge MDL Novice

    May 15, 2016

    I have been attempting to upgrade the video card in my Asus F8SP laptop (AMI BIOS, Core 2 Duo, Vista era). I didn't have much luck inserting the orom for the new card in the existing firmware; it booted and displayed an image, but the keyboard kept being ignored as soon as I got into the BIOS setup (the F2 press worked, but nothing else), while if I hit esc to bring up the boot options menu, that gets ignored always (so no keypresses work). If I allow it to go to the GRUB boot menu, the keyboard is completely ignored again... well, I am getting ahead of myself, as that's hardly my main concern now.

    The F8SP comes with an ATI card; the new one is Nvidia, and another F8 variant, the F8SN, uses an Nvidia card that uses the same OROM (though with a different hardware ID) that I had inserted in the SP bios (same hash). It seems that all of the F8S series use the same board with different firmware, so I took the F8SN firmware and edited the occurrences of F8SN with a hex editor and changed them to F8SP so that the flasher would go with it. It did.

    Well, it's bricked. I knew it was a bad idea... but no guts, no glory; though right now there's no glory either. Hitting power results in the power LED coming on and the fan spinning at a low speed, but no image on-screen and no sounds of any kind. The optical drive, though, does spin up, so there's hope, I hope.

    I tried burning a CD ROM with AMIBOOT.ROM (renamed stock F8SP firmware) as the only file on it on my other PC, then turning on the laptop with that CD inserted. The optical drive spins up and whirrs a while, then stops; nothing else happens. I tried it also with a USB drive formatted FAT32 (it is also my DOS boot device for flashing), with the file renamed as before to AMIBOOT.ROM, but the laptop did not seem to recognize the drive; the light never flashed on it. I tried turning the laptop on with home and ctrl held down; it was the same as turning it on with no keys held (the optical drive whirrs, then nothing happens, and the thumb drive does not flash at all).

    I tried with a DVD (I didn't have any more blank CDs) with the stock F8SN firmware too, renamed again to AMIBOOT.ROM, in case somehow it was convinced that's what it needed; no difference. Tried it also with the unrenamed file as it came from ASUS on the DVD; nothing. I also tried turning it on with the recovery DVD that came with the laptop... same again.

    The motherboard does not seem dead. If I open the optical drive and pop a new disc in, it accesses it immediately and whirrs a bit, then stops; it's trying to get that recovery firmware, it seems, but for some reason, it is not working.

    Is there a way to resurrect it? It seems that it may want another filename besides AMIBOOT.ROM, but I was not able to find out anything searching the topic, and the ASUS renamer tool I tried didn't even recognize the F8's firmware file.