Need help with Dell AIO 926 Printer

Discussion in 'PC Hardware' started by nintenpc, May 28, 2012.

  1. nintenpc

    nintenpc MDL Novice

    Dec 12, 2011
    33
    6
    0
    I have a Dell AIO Photo 926 printer that I use with my Windows 7 SP1 x64 machine. This printer worked fine with my old XP machine, but ever since I upgraded to a Windows 7 rig in 2009, I have been having issues. At first I thought it was working fine, but then when I tried scanning, I found that the scan driver did not work. After uninstalling and reinstalling the software many times, I got both scanning and printing to work at the same time, but now I have additional problems:

    Whenever I scan something, "Job Status Window Interface" crashes twice after it finishes, though the scan completes successfully. This happened when printing as well until I ran the offending exe in administrator mode, but now the progress bar that used to pop up when printing no longer appears (not that I miss it but wtf).

    Sometimes I receive an error message telling me that communication with my printer failed. I must restart my computer to correct this when it happens.

    Sometimes, when scanning, the driver crashes and I have to use Process Hacker to kill all of the software components of my printer in order for scanning to work again. Sometimes I have to do this multiple times. If I still have Process Hacker open from the last time, I can actually watch the driver crash.

    I have tried the following resolution with no success:

    1. Uninstall all of the software that came with my printer. (Reboot)

    2. Run a cleanup utility Dell released to remove all the crap the uninstaller missed. (Reboot)

    3. Edit the registry to remove all compatibility references to anything Dell related.

    4. Run CCleaner to remove all junk files from my system and fix all registry errors.

    5. Reinstall the latest drivers in compatibility mode for Windows Vista.

    I thought that this my just be a compatibility problem with Windows 7 as the x64 drivers appear unchanged since XP, but other users have reported that they have gotten it to work without problems.

    I posted on Dell forums as well but gave up when the responses started to become robotic. They linked me to a Lexmark branded patch (my printer is apparently a re-branded Lexmark, not sure which model) that installed but did not fix my problem.

    Any help would be greatly appreciated. This is driving me nuts.
     
  2. gabris[LT]

    gabris[LT] MDL Senior Member

    Nov 6, 2010
    434
    243
    10
  3. nintenpc

    nintenpc MDL Novice

    Dec 12, 2011
    33
    6
    0
    I tried that solution and it changed nothing.

    I have been using those drivers.