network adapter problem

Discussion in 'PC Hardware' started by ibnyinc, Apr 18, 2010.

  1. ibnyinc

    ibnyinc MDL Novice

    Apr 18, 2010
    7
    0
    0
    new here not sure im in the right place i need help fixing my bios for my sony vaio laptop model # vgn-fz140e pheonix bios ver r2060j9 please help thanks.

    i bought a battery from ebay and the battery came with a disc driver that had to be installed before the battery can work. i installed the driver but what it does is flash the bios with an update for the battery. long story short the battery does not work and will return it but i am having problems now with my network adapter is gone does not see it at all. i treid to flash the bios with the backup that the battery update made but still no success still having problems with the network eithernet adapter. i think the update flash screwed up my original bios and i cant find the original bios anywhere. sony website does not have it. does anyone have or know where i can download the original bios for my laptop or have any ideas how to fix this problem any help will be great thank you.
     
  2. bp1

    bp1 MDL Member

    May 11, 2009
    208
    50
    10
    Have you tried to set the bios to load default settings or "Load Bios Defaults" , "Load Setup Defaults" , "Safe Settings", "Load Optimized Defaults",
    You say that the motherboard bios has been updated. You will need to goto the bios and carry out the above probably
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ibnyinc

    ibnyinc MDL Novice

    Apr 18, 2010
    7
    0
    0
    yes i did that but it just sets cmos to default still the os is not detecting the network adapter from the bios
     
  4. icewater

    icewater MDL Novice

    Dec 3, 2009
    34
    0
    0
    #5 icewater, Apr 19, 2010
    Last edited: Apr 19, 2010
    This model has the same chipset as your laptop and it lists a BIOS file which may be the same as your original BIOS but It would be risky to flash.

    *EDIT, never mind, not the same.
     
  5. ibnyinc

    ibnyinc MDL Novice

    Apr 18, 2010
    7
    0
    0
    now i know it was not an oem i know i was asking for trouble to flash the bios to make a battery work but it stated it was a driver so i installed it and could not stop in the middle of it. the seller did sell a few of them and had good feedback so i took a chance not only does it not work but now the adapter as well and the return shipping and time wasted big mistake o well live and learn. i did try contacting sony and got a reply back that they dont have the bios or an update. thanks for the ftp but they dont have my bios listed and i am afraid to flash with any other as my laptop still works flashing it with an unknown could make it useless. thanks for trying i dont know what im going to do now.
     
  6. icewater

    icewater MDL Novice

    Dec 3, 2009
    34
    0
    0
    Im surprised their tech support didnt help. Have you tried contacting the ebay guy? He may have an original BIOS he can send you, he has probably seen this problem before. Hopefully you didnt already leave good feedback.

    I would also try to contact Sony again, say something like "My laptop is in the shop and the tech working on it needs the original BIOS, please email it to me."
     
  7. ibnyinc

    ibnyinc MDL Novice

    Apr 18, 2010
    7
    0
    0
    i wrote to the ebay guy didnt return my email yet. sony said they dont have and dont send out the bios, they want me to send it to a sony authorized service center for them to repiar it but thats big bucks. my only chance seem to locate someone with the same model # and have them backup the bios and send it to me but what are the chances of that happening im screwed.
     
  8. icewater

    icewater MDL Novice

    Dec 3, 2009
    34
    0
    0
    Troll some Sony or laptop forums until you find someone with the same model.
    Sorry dude, good luck.