Networking head scratcher... I'm really stumped by this.

Discussion in 'Windows 7' started by donalgodon, Feb 24, 2011.

  1. donalgodon

    donalgodon MDL Member

    Jul 21, 2010
    161
    2
    10
    #1 donalgodon, Feb 24, 2011
    Last edited: Feb 24, 2011
    I have a Sony Vaio that has a clean installation of Windows 7 Ultimate and all Ethernet and Wireless drivers. I can connect flawlessly and rock-solid at home, but I cannot connect at work, no matter what I try. I've tried direct Ethernet connections without a firewall, checked my IP, but I get only a connection to the router itself and no internet access. It always shows the same: Connected. No Internet access.

    I had the network admin there in the office check the IP assigned to my Vaio with another 2 laptops (HP) and they both picked it up when assigned this IP, but mine won't. I tried assigning it three different open IP addresses, all of which failed. Connected. No access. No access either wired or wirelessly.

    I'm really stumped here. Can anyone offer any suggestions? The diagnosis tools in Win 7 didn't help one bit. Surprise.
     
  2. donalgodon

    donalgodon MDL Member

    Jul 21, 2010
    161
    2
    10
    Sony says to disable IPv6 protocol. Could it really be so simple? I'm a little skeptical. What does this do?
     
  3. dewot

    dewot MDL Junior Member

    Apr 25, 2008
    57
    17
    0
    Could very well be. Some older equipment may require IPV6 support to be enabled, or may not support it at all. Try downloading a little utility from nirsoft called currports. It will show you all your open ports / connections, and supports both IPV4 and IPV6. IPV6 conections have ":" separators.

    I sometimes have to use a dial up connection out in the country, and the ISP does not yet support IPV6 on dialup - heck, they may never. Google "disable IPV6 in windows 7" and you will come up with a registry entry to turn it off.
     
  4. Kouryu

    Kouryu MDL Senior Member

    Jan 19, 2011
    408
    111
    10
    do you have vmware or anything else of the sorts installed (virtualbox, virtualpc, etc)?
    is the router at work a d-link?

    if both are true, then it is a bug in the d-link firmware... I had this issue before on my laptop connecting to ANY d-link router

    disabling the vmware network adapters in device manager let me route afterwards... totally weird


    you should also copy and paste the routing table report here....
    run an elevated command prompt by clicking on "start", typing in "cmd" in the search box... right click on the first result and click "run as administrator"
    then type in "route print"
    if you have trouble copying from command prompt, then redirect the output to a text file.... such as "route print > report.txt"


    paste it here and let's see whats going on