New HP ML110 not recognizing stock HDD

Discussion in 'Windows Server' started by dephtonial, Sep 11, 2016.

  1. dephtonial

    dephtonial MDL Novice

    Sep 11, 2016
    2
    0
    0
    New to the forums and looking for a little help.

    I've installed many OS' and am (reasonably) tech savvy, so maybe I'm just missing something obvious.

    Bought an HP ML110 and it came with a 1TB HP Enterprise SATA drive. It boots into the EUFI interface and I change the boot order to install Windows Swrver from the USB I inserted. During the install, WS asks which drive but there are none listed. Only an option to Refresh and Load Drivers.

    My first thought is that it's not formatted? But if that's the case wouldn't the install process format it? It's like the process doesn't recognize the computer even has a drive.
     
  2. ofernandofilo

    ofernandofilo MDL Member

    Sep 26, 2015
    211
    128
    10
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. dephtonial

    dephtonial MDL Novice

    Sep 11, 2016
    2
    0
    0
    First, thank you for your time!

    I don't mean to sound dense, but given the installation instructions below how do I follow them if I don't have an environment in which I can extract and execute files such as these?

     
  4. ofernandofilo

    ofernandofilo MDL Member

    Sep 26, 2015
    211
    128
    10
    #4 ofernandofilo, Sep 12, 2016
    Last edited: Sep 12, 2016
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. mightymoose

    mightymoose MDL Junior Member

    Dec 4, 2009
    71
    2
    0
    For God's sake, you aren't "tech savvy" and you ARE incredible dense. ofernandofilo provided you with the drivers you need. Create a directory on the usb stick you are installing from, extract the driver files to that directory and during the install, when it cant find the storage, point the windows installer to the directory you created. Comprende' ? o_O
     
  6. alea

    alea MDL Novice

    Aug 8, 2009
    5
    0
    0
    Why don't you use the HP SPP to install the OS? I'ts always the best solution, it contains driver and firmware :eek:
     
  7. tlgjaymz

    tlgjaymz MDL Novice

    May 28, 2015
    2
    2
    0
    #7 tlgjaymz, Sep 26, 2016
    Last edited: Sep 26, 2016
    Another thing to check: Has the drive been defined as a logical disk in the B140i controller, if it's in RAID mode? Because this may not have happened automatically. You're going to have to hit the setup prompt for the controller when it comes up as it boots to check, if you still can't see drives after loading the proper drivers.

    Google "hp b140i smart array user guide" and the first link should be the user guide in PDF format.

    By the looks of things, it can be configured as a RAID controller, or just a straight up SATA AHCI controller. Seeing as you only have one drive, I'd recommend just sticking with the SATA AHCI mode. The bottom of page 6 of the B140i user guide tells you how to do or check that.