No Secure Boot options visible even after flashing BIOS mod on Acer Aspire 5552

Discussion in 'BIOS Mods' started by Snowdogs, Sep 22, 2015.

  1. Snowdogs

    Snowdogs MDL Novice

    Sep 18, 2015
    2
    0
    0
    Hi forum, been going through some "training" on an Acer 5552 notebook. I was planning on a wipe and fresh install of Linux Mint and ran into problems booting to my flash drive even after setting it first in the boot sequence and trying the boot menu. I have the UEFI BIOS in 3 of my homebuilt desktops without any problem, obviously they aren't proprietary like something factory built.
    This is the first I've run into BIOS issues in 20 years of PC building and repair except for a whitelist problem with an old Thinkpad and a WIFI card.

    So I have flashed this machine to one of the modded 2.14 BIOS's from here and everything works great, all tabs unlocked, but I still have yet to see any dialog line for Secure Boot. I have tried setting an Admin. password and still no sign of the Secure Boot. And it still won't allow booting to the USB drive, which works great in my desktops.

    This is Insyde 3.5, but the screenshots I have seen showing the Secure Boot are on the 3.7 version. Is there something I am missing here?
     
  2. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,431
    1,486
    180
    disable d2d recovery and enable F12 menu?
     
  3. Snowdogs

    Snowdogs MDL Novice

    Sep 18, 2015
    2
    0
    0
    I had tried that, but no Secure Boot line appeared. I don't think that the 3.5 version of Insyde has this, I have not seen it in any screenshots, only ones of 3.7.
    I have solved my issue, my bootable flashdrive with Linux wasn't set up correctly.

    What ever happened to the good old days of A and C prompts?!
     
  4. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,641
    15,558
    340
    Aspire 5552 is a Windows 7 era laptop & thus doesn't support Secure Boot & UEFI booting.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...