Nvidia 7800 GS problems on SP1.

Discussion in 'Windows 7' started by netmaniack, Jan 27, 2011.

  1. netmaniack

    netmaniack MDL Novice

    Jul 30, 2009
    49
    2
    0
    Hi.

    I have a problem whit Nvidia 7800 GS problems on SP1 (leaked integrated retail iso) on 3D performance. It is really poor, almost like I have not installed the driver. :D Drivers are the latest.

    Anyone have similar problems whit Nvidia cards?
     
  2. KotaXor

    KotaXor MDL Senior Member

    Aug 3, 2009
    259
    6
    10
    Sometimes it is not advisable to use the latest drivers.
    Its better to use its original drivers.
    I have Nvidia card on my laptop and two desktop.
    Only one of the desktop have the latest driver and its working well.
    The rest, I have to revert back to the original driver which might be one or two version back as I have encounter problems, such as when playing games, it refuse to go to full screen even after setting it in Nvidia Control Panel.

    Try reverting the driver to older version and see if it helps.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. netmaniack

    netmaniack MDL Novice

    Jul 30, 2009
    49
    2
    0
    Will try, but far as I remember that has problems also. :S
     
  4. w7pro

    w7pro MDL Novice

    Dec 30, 2010
    6
    0
    0
    I second this. My friend had a similar issue and when he rolled back the driver, it went back to working capacity. I'm not sure if it will work in every case, but it certainly work for him.

    -- Ryan
    Windows Outreach Team
     
  5. Kouryu

    Kouryu MDL Senior Member

    Jan 19, 2011
    408
    111
    10
    I have a 7600GT in another box... I put in the latest drivers and on boot up, the screen will go blank for like 4-5 times... the CRT monitor goes crazy and the relay clunks like crazy! So I had to go back like 3-4 versions (forgot which version) to make it behave better... still does the flashing screen thing like 3 times but it's longer in between each one. This is retarded, when can nvidia make proper drivers? As much little problems as ATI has, they don't have any of these issues! So I'm sticking to ATI for now.
     
  6. netmaniack

    netmaniack MDL Novice

    Jul 30, 2009
    49
    2
    0
    Default driver crashes PC. :D Whitout BSOD, just reboot.

    Tried earlier versions, the same.
     
  7. Night_Mare

    Night_Mare MDL Novice

    Jan 23, 2011
    7
    0
    0
    Using older drivers isnt always a good thing, my 8600M has good performance with 266.58 from nvidia. My WEI is .1 less than on W7(Using SP1) .
     
  8. KotaXor

    KotaXor MDL Senior Member

    Aug 3, 2009
    259
    6
    10
    It might be the graphic itself....try it on another PC and see if it work fine.
    Or get another graphic card installed in this PC and see how it goes.

    You need to do some trial and error to get to the root of the problem.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. netmaniack

    netmaniack MDL Novice

    Jul 30, 2009
    49
    2
    0
    My new multicore AMD processor was fault. Back to Win Xp and no problems. Win 7 whit only one enabled core worked fine.
     
  10. Kouryu

    Kouryu MDL Senior Member

    Jan 19, 2011
    408
    111
    10
    time to get it replaced
    this isn't the reason to use XP lol
     
  11. KotaXor

    KotaXor MDL Senior Member

    Aug 3, 2009
    259
    6
    10
    Agreed, multi-cores is the way to go.....with one core, you are back to Pentium 4 days.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...