office 2010- unable to delete registry -"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office

Discussion in 'Microsoft Office' started by honeypot, Oct 1, 2010.

  1. honeypot

    honeypot MDL Novice

    Oct 1, 2010
    4
    0
    0
    hello experts,
    i've deleted my office 2010 software because i repeatedly got error message: 0xC004F056 .
    i first used "revo uninstaller pro", then i used the "microsoft cleanup utility", after which i went manually to check the registry and each time it was mostly clean except for the registry folder "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office".
    every time i try to delete it or any of its subfolders and keys i get this message: "cannot delete office: error while deleting key".
    i tried playing around with permissions hoping it might work, but it didnt.
    i tried leaving it there and reinstalled my office software (at least 3 times), but i still get the 0xC004F056 error message.
    i must get rid of it - so please your advice.
    thanks.
     
  2. unknownzd

    unknownzd MDL Member

    Jul 28, 2008
    129
    18
    10
    Have u tried to set / edit the permission for it before delete it?
    Try to do so in registry editor please (regedit.exe)
     
  3. honeypot

    honeypot MDL Novice

    Oct 1, 2010
    4
    0
    0
    i enter through:run -- regedit
    i played around with the pernissions, but honestly i dont know quite what to do and it didnt help me solve the issue.
    can u explain what i should do specifically?
    thanks!
     
  4. unknownzd

    unknownzd MDL Member

    Jul 28, 2008
    129
    18
    10
    If you are the admin of the computer / knowing the username of your account, navigate to "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office" now

    And then right click on it (the folder), choose "Permissions..."

    In the dialog opened, click "Add" and type in one of the following things

    - Adminstrators
    or
    - Your own user name

    Then press enter or OK

    After that, you will see that the name / group has been added to "Group or user names" now

    So click on it (the username / group that you have added) .... and choose the "Full Control - Allow" box below ..... in case any of the Deny box is checked, also uncheck them now ...... press OK and then try to delete it now

    btw remember to stop "Office Software Protection Platform" service before doing so (in case it is still running) ...... you can do that by enter "net stop osppsvc" in command prompt (cmd.exe)

    btw remember to run these tools (regedit.exe and cmd.exe) with admin privilege too
     
  5. honeypot

    honeypot MDL Novice

    Oct 1, 2010
    4
    0
    0
    alright, so i've done all that but it wont "allow" me everything (even if in "advanced" i get everything checked), and still i'm unable to delete anything in that registry folder.
    [i tried to post an image of what's going on but the site wont let me yet...]

    i also tried to install office without kms (timesurfer activation - which failed), and still got the same error 0xC004F056 which i'm now convinced is related to this registry entry - i must delete it if i want to activate office.
     
  6. unknownzd

    unknownzd MDL Member

    Jul 28, 2008
    129
    18
    10
    Have u tried to take ownership on all subcontainers and objects yet in the Advanced dialog?

    btw you should choose Replace all child object permissions too (on the Permissions tab of Advanced dialog)
     
  7. honeypot

    honeypot MDL Novice

    Oct 1, 2010
    4
    0
    0
    #7 honeypot, Oct 2, 2010
    Last edited: Oct 2, 2010
    (OP)
    the ownership thing was the way to go apparently.
    thank you so much!!
    [tried to figure out how to thank u officially, but couldnt. gave rep 8) ]