Optical Drives In Windows Explorer?

Discussion in 'Windows 10' started by DeathStalker77, Dec 12, 2016.

  1. DeathStalker77

    DeathStalker77 MDL Senior Member

    Nov 8, 2009
    332
    20
    10
    Hello all!

    I am not seeing my optical drives in Windows Explorer unless there is a disc in them. Yes, I have "Hide Empty Drives" unchecked.

    Thanks!
     
  2. pf100

    pf100 MDL Expert

    Oct 22, 2010
    1,159
    1,555
    60
    I can only see empty optical drives on my computers under "devices and drives" in the right side of file explorer when I select "This PC" on the left side. If that works for you, select open file explorer to this pc instead of quick access. Other than that, I don't know.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,542
    5,010
    210
    You may try as these icons are not shortcuts, right click on desktop, select personalize. then when Settings pops up, select Themes/ then desktop icon settings, then select which icons you want on your desktop, I would select all of them, these are real, the one's on your desktop, right click on each, select properties, if it says Shortcut, delete those. Make sure you get My PC if not all.:D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. DeathStalker77

    DeathStalker77 MDL Senior Member

    Nov 8, 2009
    332
    20
    10
    It's not the biggest thing, but it's a bloody annoyance when you're used to one thing and someone makes a *stupid* change like that ........ <grumble>
     
  5. pf100

    pf100 MDL Expert

    Oct 22, 2010
    1,159
    1,555
    60
    Welcome to Windows 10.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. dhjohns

    dhjohns MDL Guru

    Sep 5, 2013
    3,276
    1,731
    120
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. enigma101

    enigma101 MDL Novice

    Sep 1, 2015
    4
    0
    0
    Have you checked under Control Panel/Administrative Tools/Computer Management/Disk Management to see if the optical drives have a letter allocated? If they haven't, under Win 10 this can be done with an empty drive.
     
  8. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,542
    5,010
    210
    #9 lobo11, Dec 13, 2016
    Last edited: Dec 13, 2016
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...