OS allocates SSD and new mecanical HDD but not additional internal HD

Discussion in 'Windows 7' started by Orgon, Mar 7, 2016.

  1. Orgon

    Orgon MDL Junior Member

    Jul 10, 2011
    67
    0
    0
    #1 Orgon, Mar 7, 2016
    Last edited: Mar 7, 2016
    Hello
    W7 SP1 (X-64) on new SSD is configured in BIOS as first bootable drive and works fine.Additional mechanical HD (new 1TB) is formatted and is used for storage.
    Problem is that two of my older (internal) drives - also added internally to the existing SSD and new HDD (1TB) - with back-up storage for OS, music, photos, games, documents, videos, pictures, ... is not recognized at all by Disk Management in W7.In BIOS the two HDD are recognized as Maxtor and Fujitsu, but why do these not appear in OS?
    Probably an easy correction in BIOS menu, but when changing between the available modes for hard drives (AHCI, IDE, or RAID) the bootable SSD is not working because OS is installed on it.(Maybe I've omitted an important activation in BIOS? :eek: )
    I've done something wrong and appreciate professional help.
    All drivers are uppdated via SlimDrivers [not windows Update Utility].


    Motherboard:
    ASUS P6 Deluxe V2


    1. SSD drive is optimised by running in setting mode AHCI and uses SATA cable connected to ICHR10R.
    2. HDD + HDD is connected with flat cable to a fully working adapter card attached to PCI 2 slot.
     
  2. Orgon

    Orgon MDL Junior Member

    Jul 10, 2011
    67
    0
    0
    @OZ.
    Indeed, the cable is old school IDE type connected to the additional expansion-card that in turn is (also) connected to one of the available PCI 2 slots on the mobo.This set up worked since the day it was fitted in the X-58 Chipset :biggrin:.
    I followed your information on "Add Legacy Hardware" but had to abort any further installation of driver because of insecurity of installing the wrong driver to the computer that has all latest drivers installed.To that, admitting [:eek::eek::eek:], there is no possibility for me to find any information for this additional "expansion-card" (or adapter) that was installed many years ago by an experienced professional computer tech person, which had all this info on his "old" bootable floppy drive.Today, when asking in a computer store for help, there is no one who can assist because they don't know of any such adapter ever existing.
    BIOS recognizes my "old" drives, but how do I get W7 to find it when Disk Management can only find the the 2 HDD (for back-up) and SSD (system disk)?
    Sorry for extensive writing, but my system has been down after a major disk crash caused by a forced update for my W7 X64 SP1 that I did not agree with the "transistion" to W10 and unchecked the download box [WU] to NOT install W10 at all.This time I have done a clean install of W7 X64 SP1 on a new SSD and am still in trial mode for 17 days.I know Daz Loader (although flagged as "adware") by MSE is doing its work correctly, as it did with my previous version of OS, and am using it this time again.After that activation I am looking for a new updated (and upgradeable) M$ Outlook Office suite (like the Outlook Office enterprise) with activation keys included :tasty:.
    That's my goal.
     
  3. Flipp3r

    Flipp3r MDL Expert

    Feb 11, 2009
    1,473
    626
    60
    You must mean the Adapter Card Rom(bios) is listing the drives.
    Do you have the drivers installed for this card? Have you checked device manager?
     
  4. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,264
    1,422
    180
    try another pci slot and yes check driver.. model of pci ide adapter?
     
  5. Orgon

    Orgon MDL Junior Member

    Jul 10, 2011
    67
    0
    0
    @ Flipp3r
    SlimDrivers informs me that all drivers is installed and no updates available.Device Manager tells me that all hardware utilities has the updated drivers installed via specific search for each driver.Still NO sight of the HDD + HDD in W7 :confused:.
     
  6. Orgon

    Orgon MDL Junior Member

    Jul 10, 2011
    67
    0
    0
    @ LatinMcG
    It is difficult to find the model of PCI adapter because the brand name is not visible on the circuit board adapter with the PCI-IDE slots.
    How do I find it?
    Help is needed.
     
  7. Flipp3r

    Flipp3r MDL Expert

    Feb 11, 2009
    1,473
    626
    60
    When the rom lists the drives doesn't it give you more info? Rom version, etc?
    What about a photo of the card? Maybe you could ID the chipset on it?
     
  8. Orgon

    Orgon MDL Junior Member

    Jul 10, 2011
    67
    0
    0
    @ Flipp3r
    Well, the card is really snuggly fit in its* slot on the mobo and manually taking it out [also flipping the power switch on the back to off] is not my number one priority.But, I do have logg on installed 32 drivers from SlimDrivers.
    I can try posting all the 20 Log Files from the unregistered SlimDrivers.But assistance is needed so I integrate the files correctly in the next reply.
    ?????? :confused: :eek: How do I post the log files :eek: :confused: ???????​
     
  9. Orgon

    Orgon MDL Junior Member

    Jul 10, 2011
    67
    0
    0
    Right now I'm checking information in the Computer Management Panel and found that two of the drivers for Other Devices is missing (and have to be updated).


    1. Mass Storage Controller Properties => Location: on PCI bus 7, device 1, function 0 The drivers for this device are not installed. (Code 28) and, To find a driver for this device, click Update Driver.
    2. Unknown device Properties => Location: on Intel(R) ICH10R LPC Interface Controller - 3A16 informs me that The drivers for this device are not installed. (Code 28) and, There is no driver selected for the device information set or element.Furthermore it also states To find a driver for this device, click Update Driver.

    ​So, my newbie question, is if this is the actual root of the problem as the IDE ATA/ATAPI controllers and IEEE 1394 Bus host controllers have all working drivers?
    (I do have a 3 in 1 scanner unit that has a driver to be downloaded but it is connected via external USB port.Maybe it is not the problem that is found in Computer Management?)
    Hopefully there is the correct answer for this "common" problem that might happen when downloading new drivers [that I have no clue to what it is fetching] from the software slimDrivers, due to the total lack of CD/DVD with original drivers?
    Appreciating solution to this problem prior to activating new OS.After that WU without the W10 Pro activations is okay for this system :).
    P.S.
    I did not manage to post the log file from SlimDrivers.Sorry, it is very complicated :eek: :eek: :eek:.
     
  10. Flipp3r

    Flipp3r MDL Expert

    Feb 11, 2009
    1,473
    626
    60
    "Mass Storage Controller" -> Go to Device Mananger, select this, right click & select Properties, Select Details then from the drop down choices select Hardware ID.
    Copy the ID & paste it in Google to find drivers/info.

    The LPC Interface Controller is probably the Asus ATK0110 utility/driver. Not important at all. Look up your motherboard on the Asus site & download it if you wish...
     
  11. Orgon

    Orgon MDL Junior Member

    Jul 10, 2011
    67
    0
    0
    @ Flipp3r
    Mass Storage Controller found these under Hardware ids
    1.) PCI\VEN_1095&DEV_0680&SUBSYS_06801095&REV_02
    2.) PCI\VEN_1095&DEV_0680&SUBSYS_06801095
    3.) PCI\VEN_1095&DEV_0680&CC_018000
    4.) PCI\VEN_1095&DEV_0680&CC_0180
    Googling gives me driver update from driverguide.com for 1.), but i do no know which driver to choose from? I chose any one of available that is not too craving for space.
    For 2.) is the same. [I chose any one of available that is not too craving for space.]For 3.) is the same.[I chose any one of available that is not too craving for space].For 4.) is the same.
     
  12. Orgon

    Orgon MDL Junior Member

    Jul 10, 2011
    67
    0
    0
    @ Oz

    Continued by first following the tip with restore point and try the Legacy Hardware in Windows for old card.Hope this will not mess up my system?
    If I manage to restart computer and still have the same issues, then I will call an IT- tech guy which will assist me correctly, unless you might have a rock solid solution.
    So, here it goes...
     
  13. Orgon

    Orgon MDL Junior Member

    Jul 10, 2011
    67
    0
    0
    :( :( :( .... :confused:
    Geez, this is really impossible to manage.
    The Information is still the same with the HDD: not allocated in Computer Management.
    Second driver (that is downloaded via Driver Identifier) is not found.So, in lack of patience (and being dumb), I let the Windows search for the software online.I guess it is not finding it.
    I followed the tutorial from the youtube on how to download and locate the file(s) but the latter missing Mass Storage file is not found.
    My hope is running low due to insecurity of doing the wrong things so far with my trial and error state for using the 3 mechanical HDD along side with the flash SSD (running in AHCI mode) and the extra new 1TB HDD (for extra space).:( and getting more :mad: because of my newbie inexperience.
    Please guide me in the right direction as time is not in my favor after 3 months of struggle with system crash :weep:.
     
  14. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,639
    1,918
    210
    A simple solution for your problem may be is the use if a IDE to USB adapter for IDE Harddisk. To power up the IDE HDD, just use the internal normal HDD Power Connector.

    On the other hand, if you take out the PCI Controller Card, you should be able to get the IC ID for the Controller chip and that would give you required infos from a Google Search about the manufacturer of that PCI Controller card. Als, even if the Controller Brarnd isn't shown on that Card, there will be a PCB ID, for which you could search either.

    Maybe those card is so old and even supports old OS'es only, you'll never able to get it to work in conjunction with latest Hardware! The cost of a good IDE PCI Controller, is in Thailand below 10 US$! And that would have driver able to work even with Windows 10!

    That last said, save time and even money (because a techy is more expensive than e new controller would be!!) and buy a , with todays OS'es working, new PCI Controller!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. Orgon

    Orgon MDL Junior Member

    Jul 10, 2011
    67
    0
    0
    @ pisthai
    I'll take your advice as a last resort: IDE PCI Controller is surely the cheapest way out of this mess ;).
     
  16. Orgon

    Orgon MDL Junior Member

    Jul 10, 2011
    67
    0
    0
    @ Flipp3r
    Yes this is the correct controller ID.Now, the question is which one of the 6 alternatives from the list is the one that is missing?
    How do I know if the last file (X-64) is the one that is missing - again trial and error?
    :confused::(:weep:
     
  17. Orgon

    Orgon MDL Junior Member

    Jul 10, 2011
    67
    0
    0
    @ Flipp3r

    Sucessfully downloaded the advised driver for OS W7 X-64 (corresponds to the system OS in SSD) and followed the information in "tutorial" from W7 that displayed the drivers being installed in the right hand corner of the task bar shown with a (mini) ikon with a green dot.
    However, before the installation I checked the Computer Management for the driver location situated under Storage Controllers.Thereafter I proceeded in this following way:
    Computer Management=>Device Manager and under Storage Controllers there is driver from Marvell 61xx RAID Controller installed and working.
    When clicking Update Driver Software a choice of three alternatives is available.1.) Generic Marvel 61xx RAID Controller.2.) Marvel 61xx Raid Controller.3.) Standard Dual Channel PCi IDE Controller.
    Reading information from above, the driver installed is from Marvell and is not the same as the new "old" driver downloaded from the link in post #20 that is available from the main link in post#17.
    To that Windows gave me a STOP sign that it is not able to download any driver which is the result after clicking the button Browse My Computer For Driver Software (that I just downloaded).And, after not finding its path in the BROWSE button, then I chose Let me pick from a list of device drivers on my computer.
    Here I am really confused as there are 3 alternatives - identical to the information from the Computer Management window - to choose from:
    1.) Generic Marvel 61xx RAID Controller
    2.) Marvel 61xx Raid Controller
    3.) Standard Dual Channel PCi IDE Controller


    What am I supposed to do :confused: :confused: :confused:?
    :g:
     
  18. Flipp3r

    Flipp3r MDL Expert

    Feb 11, 2009
    1,473
    626
    60