Pausing Windows 10 Updates Indefinitely

Discussion in 'Windows 10' started by shewolf, Mar 17, 2019.

  1. shewolf

    shewolf MDL Senior Member

    Apr 16, 2015
    387
    925
    10
    #1 shewolf, Mar 17, 2019
    Last edited: Mar 18, 2019
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. rpo

    rpo MDL Addicted

    Jan 3, 2010
    742
    519
    30
  3. shewolf

    shewolf MDL Senior Member

    Apr 16, 2015
    387
    925
    10
    #3 shewolf, Mar 17, 2019
    Last edited: Mar 18, 2019
    (OP)
    Wauuu.., It was really super fast and perform the mission perfectly I must say bravo , now let's think about fine tuning ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. shewolf

    shewolf MDL Senior Member

    Apr 16, 2015
    387
    925
    10
    For my taste I would make a small correction instead of WUMT starts -update auto

    Capture.PNG

    I would let it be manual

    Capture2.PNG

    So that the user can choose between the options

    Capture3.PNG

    And start scan manually.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. shewolf

    shewolf MDL Senior Member

    Apr 16, 2015
    387
    925
    10
    #5 shewolf, Mar 18, 2019
    Last edited: Mar 19, 2019
    (OP)
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. rpo

    rpo MDL Addicted

    Jan 3, 2010
    742
    519
    30
    Instruction at line 159 :
    Code:
        $epoch = Get-Date 01/15/2019
    causes an issue on my system because the date formated as 01/15/2019 is valid for US systems, but not for my French Windows. 01/01/2019 is valid for all system, but I don't know the impact when running the script.
     
  7. shewolf

    shewolf MDL Senior Member

    Apr 16, 2015
    387
    925
    10
    Everyone can adapt to himself, by changing the parameters you need nothing bad will happen.
    If it's not okay anything else you can go up with UniversalTime 01/01/1601.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. shewolf

    shewolf MDL Senior Member

    Apr 16, 2015
    387
    925
    10
    #8 shewolf, Mar 19, 2019
    Last edited: Mar 19, 2019
    (OP)
    down.PNG


    If you set WUMT to Notification Mode and Windows Update Paused you will have the beautiful pop-up You need some updates. :p
    But only for Windows Defender Antivirus (wu paused). You can update definition with WUMT or default with Windows Update.

    :eek:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. rpo

    rpo MDL Addicted

    Jan 3, 2010
    742
    519
    30
    The same applies to drivers updates.
     
  10. shewolf

    shewolf MDL Senior Member

    Apr 16, 2015
    387
    925
    10
    Yes,

    paus.PNG


    After updating, it returns auto to Pause Mode. ;)

    :eek:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. pf100

    pf100 MDL Expert

    Oct 22, 2010
    1,478
    2,069
    60
    I'm very curious about this. Have you tried this in an old version of Windows 10 that's beyond its support date to see if it tries to update?
     
  12. shewolf

    shewolf MDL Senior Member

    Apr 16, 2015
    387
    925
    10
    #12 shewolf, Apr 8, 2019
    Last edited: Apr 9, 2019
    (OP)
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    750
    127
    30
    #13 stayboogy, Apr 8, 2019
    Last edited: Apr 8, 2019
    disable your internet adapter(s) and import this registry file as an administrator--can be done from batch as so:

    reg import location\to\this\regfile\NoUpdatesEver.reg

    NoUpdatesEver.reg
    HTML:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]
    "SetDisableUXWUAccess"=dword:00000001
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
    "NoAutoUpdate"=dword:00000001
    
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]
    "DisableWindowsUpdateAccess"=dword:00000001
    "DisableWindowsUpdateAccessMode"=dword:00000000
    then reboot, then with your internet adapter(s) still disabled, go check for updates, and wait for it to fail. and give the error in the attached picture, then reboot again, then re-enable your network adapter(s) and you'll never get any updates ever. been using this for two years now. works as far as v1803 17134.1, probably even higher, i'm just using the version i like the best. [it says it will check, but it does not, mine has never checked for an update--if you leave your network adapter(s) enabled while importing this regfile and checking for updates you will still check for updates; you must follow my directions exactly, then you can leave your network adapter(s) enabled for good; if you have ever once checked and downloaded updates, this method will not work).

    Image 016.png
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...