Phoenix BIOS Editor 2.2

Discussion in 'Windows Vista' started by madhatteruk85, Oct 20, 2007.

  1. madhatteruk85

    madhatteruk85 MDL Novice

    Oct 14, 2007
    2
    0
    0
    Hi folks

    I have version 2.2 of phoenix bios editor installed on my laptop, and i'm trying to edit the 48bit LBA support option.

    Unfortunately, in BIOS Configuration Parameters>Hard Disk Features, the option to enable it is greyed out, and says "This item is read-only" when i try and select it.

    Does anyone know why that is? and that that's the only option that pretty much is greyed out?

    Thanks in advance :)

    MaD
     
  2. ancestor(v)

    ancestor(v) Admin
    Staff Member

    Jun 26, 2007
    2,707
    4,620
    90
    Maybe you need a BIOS Update. Or there simply isn't any support. Can you give any more details?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. madhatteruk85

    madhatteruk85 MDL Novice

    Oct 14, 2007
    2
    0
    0
    Bios

    Thanks for the reply.

    NEC are terrible at after support for their products in the UK. So I have aquired the Phoenix BIOS editor, with the view to enabling LBA 48bit support so my BIOS can see more than 137GB of hard disk (its actually got a 160GB drive in it).

    I've opened up the BIOS file, which for some bizarre reason isn't a WPH or ROM file, its a BIN file.

    I've enabled the option for LBA control firstly.

    When i go into BIOS Configuration Parameters, and select the option for Hard Disk Features (at point 79FF of either ROMEXE0 or ROMEXE01) but i can't click it to enable the 48 Bit support, it prompts to say that the Item is Read Only.

    It's the latest BIOS file - 3A14, and seems to work with Vista better than the previous 3A09. I've requested a later BIOS from NEC, but they just keep telling me Vista isn't supported, and we have no later BIOS than the current version on their support site.

    Can you offer any advice?


    MaD
     
  4. kocoman

    kocoman MDL Senior Member

    May 16, 2007
    328
    4
    10
    bump do you have any update?

    The "Edit" is gray out also.

    maybe need another edition of the bios editor?