[Phoenix BIOS] I can't flash back newer BIOS version

Discussion in 'BIOS Mods' started by Dryml, Feb 18, 2015.

  1. Dryml

    Dryml MDL Novice

    Sep 1, 2014
    1
    0
    0

    Hello everyone and please help,

    At the beginning I'm sorry for my english ...

    I have a problem with laptop Fujitsu-Siemens Amilo Xi1526. Almost from the news this laptop was the latest version of the BIOS - that is 1.27 (factory was flash version 1.25). Because this BIOS is poor at the functions, so out of curiosity I decided to download from the manufacturer's website and flash one of the older versions of the BIOS for this laptop - that is 1.17. Unfortunately older versions of the BIOS do not support the new features so I want to go back to the latest BIOS version for this laptop - that is 1.27. And here comes the problem, because when I try to flash back to the latest BIOS (1.27) program for flashing screaming: "This BIOS is not for this model" and the program exits. This happens because the program for flashing before start flashing BIOS procedure first checks compatibility BIOS with that is currently being uploaded in system. I tried to flash the other versions of the BIOS and I can flash version 1.15, 1.17 and earlier versions. From the BIOS version 1.20 to the latest version 1.27 then these I can not flash because the message pops up "This BIOS is not for this model". I do not know does it matter but from the BIOS version 1.20 manufacturer shall affix in the BIOS compatibility with Windows Vista.

    I'm using the official program for flashing in DOS that is Phlash16. Does not help option: /X /FORCE /C /S

    I have a question:
    1. Is there any other command to force flash BIOS in the Phlash16 without checking compliance?
    2. Is there another program which can flash the Phoenix BIOS which will not be yelling for non-compliance?

    I've included a link to the manufacturer's website where is all BIOS for this laptop:
    support.ts.fujitsu.com/download/index.asp?level1=20968&lng=en&LNID=5462

    I attach in a format WPH latest BIOS version 1.27 and version 1.20 and the highest BIOS that I can currently flash that is 1.17. Link:
    www18.zippyshare.com/v/bcBioumN/file.html
    www18.zippyshare.com/v/NfZVH7wg/file.html
    www18.zippyshare.com/v/sN3CveQb/file.html

    Can someone download these files and edit them to look what is the problem with the BIOS files that I can flash version 1.15, 1.17 and earlier versions but the BIOS version 1.20 to the latest version 1.27 then these I can not flash because the message pops up "This BIOS is not for this model" on the program for DOS that is Phlash16 and on the program for Windows that is WinPhlash the message pops up error code 144.


    Thanks in advance for help and best regards





    .
     
  2. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,719
    3,086
    300