Pidgin question

Discussion in 'Application Software' started by morphism, Dec 10, 2012.

  1. morphism

    morphism MDL Novice

    Dec 10, 2012
    10
    0
    0
    Hello,

    I'm new here, so I apologize if I'm posting in the wrong place.

    Recently, I've been having some proxy issues, and unfortunately, being as I'm very new to PCs (...and to this Website) I don't know how to fix the issue.

    I installed tor. Once I did that, I had a whole SLEW of problems, one of which was that Firefox would not connect to the Internet.

    However, Google Chrome WOULD connect. So, I re-installed Firefox, and the problem went away. Before re-instal, it said that it could not connect to the Internet due to a proxy issue.

    Now however, Pidgin will not work at all. It keeps giving me this message:



    :death:INVALID PROXY SETTINGS
    Either the host name or port number specified for your
    given proxy type is invalid


    Neither my XMPP nor my AOL accounts will work.

    Any ideas, folks?

    Oh, and also; if you saw my message in the introduction area, you'd know that I don't plan on fixing this issue and then jumping off this website. I plan on staying around for a long time, and becoming a part of the community. So, you won't be wasting your time helping someone fix a PC issue who will then just run off like a lot of people do.

    Thank you for at least reading my questions!

    All the best,

    Morphism
     
  2. morphism

    morphism MDL Novice

    Dec 10, 2012
    10
    0
    0
    I want my IM software to work again.

    I would also like to know why Firefox would not connect to the Internet until I re-installed it and uninstalled tor, while at the same time Chrome would connect just fine.

    Also, before I re-installed Firefox and uninstalled tor, I pinged to google, (...just to see if I could get ANY back-and-forth) and it worked as it should... but I could not ping to pidgin (the server for my XMPP account).

    MOREOVER, I could not ping to aol. Shouldn't I be able to ping to aol?

    Anyway:

    I need to instal/use tor, as well as BitCoin, but I don't want my IM traffic going through tor.

    This all started when I had an acquaintance of mine "trick out" my PC via Team Viewer. After that, I installed tor, and then that's when everything stopped working.

    I wanna understand what went wrong as well as get it to work again.

    After that, I want to know Windows 7 as well as he did to do whatever the heck it is he DID do to my PC to trick it out in the first place, because Firefox was running amazing!

    So, ideally:

    1. IM can go through damned proxy is the easiest.

    2. I want tor on my PC without causing me to be in the situation I'm in right now.

    ...while I'm paying attention to this thread, I'll also be reading a lot of links that people are providing for me in the intro area, so hopefully, I'll get a mental map of all of this stuff, and be able to understand AND manipulate it. Then, after being in this community for a while, consider this problem to be child's play. That's the hope, anyhow.

    Thanks for the response, 100.

    All the best,

    Morphism
     
  3. 100

    100 MDL Expert

    May 17, 2011
    1,346
    1,544
    60
    Well if you're getting proxy errors you're going to have a proxy set in your programs, which you will have to disable (Pidgin preferences, Firefox preferences, Windows internet settings, etc.). Usually you won't have to set a proxy, however, if you're on a connection that does require using one (e.g. if you're on a corporate network) these settings might need to be set differently.

    You say you want to "use Tor", but that's not very specific. Using a browser is just one way to make use of Tor; if that's what you're after, all you have to do is install the Tor browser bundle and use the Firefox that's included with it. It won't affect any of your other programs.
     
  4. morphism

    morphism MDL Novice

    Dec 10, 2012
    10
    0
    0
    #5 morphism, Dec 11, 2012
    Last edited: Dec 11, 2012
    (OP)
    For tor, I just want to use the Firefox tor browser. Vidalia was nice, but I guess the onion button no longer works. So, I'll just use the browser that comes with the bundle.

    I'm not on a corporate network. This is my home connection.

    I'll screw around with the proxy settings in Pidgin. I've read about certain ports being needed as well for XMPP through Pidgin, which I tried, with no luck. It recommended port 5222 for dealing with firewall issues, but only when an antivirus software is installed. I don't currently have one.

    I'm currently trying to find a place to disable proxies in Pidgin, and found one. I turned off proxies. Now, I get this message:

    "SSL connection failed."

    I'll read up on what SSL is. I think I'm at least making SOME headway.

    Thanks again, 100,

    Morphism

    PS: I've been using Pidgin for over 3 years now, and I've never had something like this happen. I'd be willing to just do a re-install, but then I wouldn't learn what the problem is.
     
  5. morphism

    morphism MDL Novice

    Dec 10, 2012
    10
    0
    0
    Turned off SSL, now Pidgin simply says unable to connect.
     
  6. 100

    100 MDL Expert

    May 17, 2011
    1,346
    1,544
    60
    #7 100, Dec 11, 2012
    Last edited by a moderator: Apr 20, 2017
    Yes, the default port for XMPP is 5222. An older port that was used for SSL connections was 5223, so you could try that one as well.
    SSL is used to encrypt communication between the XMPP client (Pidgin) and the XMPP server, which is why you should keep it enabled.

    If your server is using a non-standard port you can also try querying its SRV record to get the port (on a command prompt):
    Code:
    nslookup -type=srv _xmpp-client._tcp.your-xmpp-domain.com.
    Good thinking. :p
     
  7. morphism

    morphism MDL Novice

    Dec 10, 2012
    10
    0
    0
    #8 morphism, Dec 11, 2012
    Last edited: Dec 11, 2012
    (OP)
    The limitations on my account make it so that I cannot enter in either a picture of my command screen, or even type in what it says. This friggin' user interface keeps thinking I'm posting links, even when I'm not... even when I turn off the "Automatically parse links in text" it doesn't matter.

    Anyway, when I type it in, IF I'm entering it correctly (...which I can't show you, because of the damn 20-post limitation) here's what I get back:

    *** UnKnown can't find _xmpp-client.tcp.pidgin%%%%%%%%%%%su: Non-existent formula domain.

    The %%%%%%%%%%% are so that this friggin' webpage doesn't think I'm posting a link.

    I'm not posting any links, admins! Sheesus!
     
  8. 100

    100 MDL Expert

    May 17, 2011
    1,346
    1,544
    60
    Hmm. You did enter it incorrectly (it's "_xmpp-client._tcp.domain"), but even with the correct format I'm not getting anything here for pidgin.su either. Maybe they're having DNS issues?
     
  9. morphism

    morphism MDL Novice

    Dec 10, 2012
    10
    0
    0
    #10 morphism, Dec 12, 2012
    Last edited: Dec 12, 2012
    (OP)
    Yeah, my expert friend, through Team viewer, was able to discover that pidgin.su is toast.

    That's what the whole problem was.

    Thanks a bunch, friend!

    I'll obviously send you a thanks for your time. Even though the problem was something neither of us would've guessed, we got it!

    All the best,

    Morphism